Bug 236397 - www/newsboat: Bad display from an atom source
Summary: www/newsboat: Bad display from an atom source
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-08 19:47 UTC by moebius444
Modified: 2019-04-25 16:59 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (mt)


Attachments
Proposition for utils::clean_nonprintable_characters() (1.41 KB, patch)
2019-03-24 05:36 UTC, moebius444
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description moebius444 2019-03-08 19:47:29 UTC
Hi,

Using www/newsboat 2.14.1_2 from ports.
Some texts do not appear correctly from the following source

https://rss.evangelizo.org/v2/evangelizo_rss-fr.xml

Especially for the sections "Evangile...".
Where could the problem come from ?
Try using without 'config' file.
A config file with 'pager less' (or most) resolves the problem.

See : https://groups.google.com/forum/#!topic/newsboat/IhbsCs_NtFI

Best regards.

-----------------
Olivier
Comment 1 moebius444 2019-03-19 19:23:30 UTC
Another source with the same problem:

http://www.rfi.fr/emission/autour-question/podcast

Best regards

------------------
Olivier
Comment 2 Tilman Keskinoz freebsd_committer 2019-03-19 21:12:54 UTC
Hi, to narrow it down, have you tried to save the text and display it in another ncurses application like e.g. nano?

If you are on STABLE or CURRENT, have you tried using C.UTF-8 as LANG?

I am not even sure, if this really counts as a bug, as you are trying to display UTF-8 text on a locale that does not support UTF-8 (but I am not a locale expert).
Comment 3 moebius444 2019-03-24 05:36:54 UTC
Created attachment 203095 [details]
Proposition for utils::clean_nonprintable_characters()

I found that the remplacement char \uFFFD does not display correctly.
In utils::clean_nonprintable_characters(), I force \u00A0 (NO-BREAK SPACE) remplacement by \u0020.

In stfl, and via iconv, wstr2str utils::clean_nonprintable_curiously replaces space with \u00A0 (for example before ':'),  which does not suit my case.

Best regards.

----------------------
Olivier
Comment 4 Marko Turk 2019-04-12 19:50:27 UTC
(In reply to moebius444 from comment #3)

I don't feel comfortable with adding this patch to ports. We might break some other stuff.

Since the issue is not seen on e.g. Linux, the problem could be in the way we build stfl.

The only other application using stfl in ports is kdbx-viewer, I'll try to reproduce the issue there and see how it behaves with these characters you mentioned.

Have you been able to get this characters to display properly by chaning the locale that you use?

BR/Marko
Comment 5 moebius444 2019-04-25 16:59:07 UTC
I try to change locale with LANG=C.UTF-8 and for the other LC_ccc I export en_US.UTF-8. The result is the same : the text does not display correctly.

---------------
Olivier