Bug 236597 - net-p2p/monero-cli: fails to build with boost 1.70
Summary: net-p2p/monero-cli: fails to build with boost 1.70
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Vasil Dimov
URL:
Keywords: needs-patch, regression
Depends on:
Blocks: 235956
  Show dependency treegraph
 
Reported: 2019-03-17 13:49 UTC by Jan Beich
Modified: 2019-04-15 17:28 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (vd)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2019-03-17 13:49:25 UTC
While preparing for Boost upgrade this port failed to build. Can you help to avoid marking it as BROKEN?

$ fetch -qo- 'https://reviews.freebsd.org/D19303?download=true' |
  patch -Efsp0 -d /usr/ports
$ make all deinstall install clean -C/usr/ports/devel/boost-jam
$ make all deinstall install clean -C/usr/ports/devel/boost-libs
$ make -C/usr/ports/net-p2p/monero-cli
[...]
In file included from .../work/monero-0.13.0.4/src/rpc/daemon_handler.cpp:29:
In file included from .../work/monero-0.13.0.4/src/rpc/daemon_handler.h:36:
In file included from .../work/monero-0.13.0.4/src/p2p/net_node.h:41:
In file included from .../work/monero-0.13.0.4/contrib/epee/include/net/levin_server_cp2.h:32:
In file included from .../work/monero-0.13.0.4/contrib/epee/include/net/abstract_tcp_server2.h:339:
.../work/monero-0.13.0.4/contrib/epee/include/net/abstract_tcp_server2.inl:218:20: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
    return socket_.get_io_service();
           ~~~~~~~ ^
.../work/monero-0.13.0.4/contrib/epee/include/net/abstract_tcp_server2.inl:386:28: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
      size_t cnt = socket_.get_io_service().run_one();
                   ~~~~~~~ ^
.../work/monero-0.13.0.4/contrib/epee/include/net/abstract_tcp_server2.inl:396:28: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
      size_t cnt = socket_.get_io_service().poll_one();     
                   ~~~~~~~ ^
Comment 1 Jan Beich freebsd_committer 2019-03-25 10:17:28 UTC
Upstream has a fix but it needs rebasing. If we're lucky there'd be a new release with the fix included. Otherwise, I'll leave it up to you to backport it.
Comment 2 Vasil Dimov freebsd_committer 2019-03-25 11:39:56 UTC
Jan, link to the upstream fix?
Btw, you tested monero 0.13.0.4, while the latest is 0.14.0.2. Not sure if that matters.
Thanks!
Comment 3 Jan Beich freebsd_committer 2019-03-25 15:11:08 UTC
See Also bugzilla field points to upstream issue which points to the fix.

(In reply to Vasil Dimov from comment #2)
> Btw, you tested monero 0.13.0.4, while the latest is 0.14.0.2.

I tested whatever was in ports at the time and master snapshot. Turns out I did have 0.14.0.2 error log as early as 2019-03-10. As bundled epee didn't change between 0.13.0.4 and 0.14.0.2 it's pointless to post excerpt here.
Comment 4 Jan Beich freebsd_committer 2019-04-12 09:44:18 UTC
The port has been marked BROKEN in ports r498698.
Comment 5 William Elasio Moreno Albarracin 2019-04-14 22:12:32 UTC
root@server:/usr/ports/net-p2p/monero-cli # make reinstall clean
===>  monero-cli-0.14.0.2_2 is marked as broken: fails to build with boost
1.70, see bug 236597.
*** Error code 1

Stop.
make: stopped in /usr/ports/net-p2p/monero-cli
Comment 6 commit-hook freebsd_committer 2019-04-15 17:28:00 UTC
A commit references this bug:

Author: vd
Date: Mon Apr 15 17:27:55 UTC 2019
New revision: 499035
URL: https://svnweb.freebsd.org/changeset/ports/499035

Log:
  net-p2p/monero-cli: Apply all changes from upstream after 0.14.0.2

  Use git commit id 1f809e7485fc3085 instead of tag v0.14.0.2. This fixes
  the compilation with boost 1.70.

  PR:		236597

Changes:
  head/net-p2p/monero-cli/Makefile
  head/net-p2p/monero-cli/distinfo
  head/net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt