Bug 236599 - graphics/luxrender14: fails to build with boost 1.70
Summary: graphics/luxrender14: fails to build with boost 1.70
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords: needs-patch, regression
Depends on:
Blocks: 235956
  Show dependency treegraph
 
Reported: 2019-03-17 14:27 UTC by Jan Beich
Modified: 2019-09-07 11:35 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2019-03-17 14:27:34 UTC
While preparing for Boost upgrade this port failed to build. Can you help to avoid marking it as BROKEN?

$ fetch -qo- 'https://reviews.freebsd.org/D19303?download=true' |
  patch -Efsp0 -d /usr/ports
$ make all deinstall install clean -C/usr/ports/devel/boost-jam
$ make all deinstall install clean -C/usr/ports/devel/boost-libs
$ make -C/usr/ports/graphics/luxrender14
[...]
.../work/luxrender-lux-dfd211d6faa0/core/asyncstream.cpp:68:9: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
        socket.get_io_service().reset();
        ~~~~~~ ^
.../work/luxrender-lux-dfd211d6faa0/core/asyncstream.cpp:70:43: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
        boost::asio::deadline_timer timer(socket.get_io_service());
                                          ~~~~~~ ^
.../work/luxrender-lux-dfd211d6faa0/core/asyncstream.cpp:94:17: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
        while ( socket.get_io_service().run_one() ) {
                ~~~~~~ ^
.../work/luxrender-lux-dfd211d6faa0/core/asyncstream.cpp:128:9: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
        socket.get_io_service().reset();
        ~~~~~~ ^
.../work/luxrender-lux-dfd211d6faa0/core/asyncstream.cpp:130:43: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
        boost::asio::deadline_timer timer(socket.get_io_service());
                                          ~~~~~~ ^
.../work/luxrender-lux-dfd211d6faa0/core/asyncstream.cpp:155:17: error: no member named 'get_io_service' in 'boost::asio::basic_stream_socket<boost::asio::ip::tcp, boost::asio::executor>'
        while ( socket.get_io_service().run_one() ) {
                ~~~~~~ ^
6 errors generated.
Comment 1 Jan Beich freebsd_committer 2019-03-17 14:28:32 UTC
Regressed by https://github.com/boostorg/asio/commit/a72fbb0b867f . Due to Atlassian not being privacy-friendly I couldn't report upstream.
Comment 2 Jan Beich freebsd_committer 2019-04-12 09:44:16 UTC
The port has been marked BROKEN in ports r498698.
Comment 3 Rene Ladan freebsd_committer 2019-09-07 11:35:56 UTC
Expired port (this slave port and its master port) removed.