Bug 236613 - www/falkon: (poudriere) configure failed
Summary: www/falkon: (poudriere) configure failed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-18 08:02 UTC by Nuno Eduardo Simões Leal Teixeira
Modified: 2019-03-18 21:06 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments
poudriere-3.3.2: errors/falkon-3.0.1_2.log (46.65 KB, text/plain)
2019-03-18 08:02 UTC, Nuno Eduardo Simões Leal Teixeira
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nuno Eduardo Simões Leal Teixeira freebsd_committer 2019-03-18 08:02:56 UTC
Created attachment 202949 [details]
poudriere-3.3.2: errors/falkon-3.0.1_2.log

Hello,

I'm getting configure failed with poudriere.

I have both GNOMEKEYRING and KWALLET deselected.

I attached falkon error log to PR.

Thanks,

Nuno Teixeira
Comment 1 Tobias C. Berner freebsd_committer 2019-03-18 11:14:17 UTC
Moin moin

This should be fixed since yesterday

https://svnweb.freebsd.org/ports/head/www/falkon/Makefile?revision=496081&view=markup

Please update your portstree and try again. 



Mfg Tobias
Comment 2 Raphael Kubo da Costa freebsd_committer 2019-03-18 20:38:43 UTC
The fix Tobias referenced is for something else; I'm able to reproduce this error when neither GNOMEKEYRING nor KWALLET are set.
Comment 3 commit-hook freebsd_committer 2019-03-18 21:03:32 UTC
A commit references this bug:

Author: rakuco
Date: Mon Mar 18 21:02:41 UTC 2019
New revision: 496208
URL: https://svnweb.freebsd.org/changeset/ports/496208

Log:
  Depend on qt5-linguisttools at runtime too.

  This fixes bug 236613, which happens when the KWALLET option is disabled. In
  this case, we do not pull in devel/qt5-linguisttools even though Falkon's build
  system uses e-c-m's ECMPoQmTools.cmake, which requires linguisttools to be
  present. As it turns out, we need to run-depend on linguisttools to prevent
  this kind of issue anywhere.

  PR:		236613
  Reviewed by:	tcberner
  Differential Revision:	https://reviews.freebsd.org/D19629

Changes:
  head/devel/kf5-extra-cmake-modules/Makefile
Comment 4 commit-hook freebsd_committer 2019-03-18 21:05:42 UTC
A commit references this bug:

Author: rakuco
Date: Mon Mar 18 21:05:12 UTC 2019
New revision: 496209
URL: https://svnweb.freebsd.org/changeset/ports/496209

Log:
  MFH: r496208

  Depend on qt5-linguisttools at runtime too.

  This fixes bug 236613, which happens when the KWALLET option is disabled. In
  this case, we do not pull in devel/qt5-linguisttools even though Falkon's build
  system uses e-c-m's ECMPoQmTools.cmake, which requires linguisttools to be
  present. As it turns out, we need to run-depend on linguisttools to prevent
  this kind of issue anywhere.

  PR:		236613
  Reviewed by:	tcberner
  Differential Revision:	https://reviews.freebsd.org/D19629

  Approved by:	ports-secteam (blanket)

Changes:
_U  branches/2019Q1/
  branches/2019Q1/devel/kf5-extra-cmake-modules/Makefile