Bug 236625 - [PATCH] x11/xfce4-taskmanager: icons not shown, wrong wnck lib
Summary: [PATCH] x11/xfce4-taskmanager: icons not shown, wrong wnck lib
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-xfce mailing list
URL:
Keywords: easy
Depends on:
Blocks:
 
Reported: 2019-03-19 01:28 UTC by rozhuk.im
Modified: 2019-03-19 17:30 UTC (History)
3 users (show)

See Also:
madpilot: maintainer-feedback+


Attachments
patch (737 bytes, patch)
2019-03-19 01:28 UTC, rozhuk.im
madpilot: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2019-03-19 01:28:03 UTC
Created attachment 202969 [details]
patch

After switch to gtk3 icons not shown, because wnck3 should be used with gtk3, but used wnck.
Comment 1 Guido Falsi freebsd_committer 2019-03-19 08:15:02 UTC
Thanks for reporting. I'll commit after some testing.
Comment 2 Guido Falsi freebsd_committer 2019-03-19 08:34:37 UTC
BTW, this got past me in testing because I rarely use this application, so the absence of the icons did not strike my eye as something strange. I simply did not expect icons to be there!
Comment 3 rozhuk.im 2019-03-19 12:06:07 UTC
I use it every day many times.
Icons lost after migration to gtk3, it was dissapointing to me and I was thinking that it is gtk3 issue.

Tonight I build taskmanager in CodeLite to debug and fix icon missing and it does not start until I change wnck-1.0 to wnck-3.0, after start I see icons :)
Now I am looking for how to save setting in quit via tray menu.
Comment 4 Guido Falsi freebsd_committer 2019-03-19 14:36:19 UTC
I understand your disappointment.

I wanted to explain why I did not notice this regression in testing before the update.

I'm committing shortly.
Comment 5 commit-hook freebsd_committer 2019-03-19 14:39:09 UTC
A commit references this bug:

Author: madpilot
Date: Tue Mar 19 14:38:13 UTC 2019
New revision: 496260
URL: https://svnweb.freebsd.org/changeset/ports/496260

Log:
  Fix regression after migration to GTK3, icons not showing.

  PR:		236625
  Submitted by:	rozhuk.im@gmail.com

Changes:
  head/x11/xfce4-taskmanager/Makefile
Comment 6 Guido Falsi freebsd_committer 2019-03-19 14:39:48 UTC
Fix committed.

Thanks!
Comment 7 rozhuk.im 2019-03-19 16:12:46 UTC
A bit strange to not disable wnck, but IMHO configure script handle this.
Comment 8 Olivier Duchateau 2019-03-19 17:11:56 UTC
libwnck3 was enabled when I submitted my patch bug #200311, but not when it was committed.
So it is not regression! libwnck3 is targeted for Gtk3.
Comment 9 Guido Falsi freebsd_committer 2019-03-19 17:30:35 UTC
I did not mean to make any fuss about this.

Maybe my choice of words was a poor one.

By regression I meant to the regression I caused in the ports with my commit. I, due to a mistake, did not include that part of you patch, and while testing I did not notice the absence of the icons, due to the fact that I rarely use this tool, so I did not notice their absence,m not being used to the appearance of this software.

I did not intend to mean anything more than this, and did not want to put blame on anyone else.

I made a (small luckily) mistake and am sorry for that.

Thanks to rozhuk for reporting it and helping me fix it.