Bug 236677 - graphics/exiv2: causes error in graphics/gimp 2.10.8: “gimp_wire_read(): error” when opening file
Summary: graphics/exiv2: causes error in graphics/gimp 2.10.8: “gimp_wire_read(): err...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-21 01:25 UTC by Vladimir Omelchuk
Modified: 2019-07-13 15:53 UTC (History)
9 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
patch disabling -fvisibility=hidden (490 bytes, text/plain)
2019-03-25 20:36 UTC, Stefan Ehmann
no flags Details
v1 (1.09 KB, patch)
2019-07-13 09:35 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Omelchuk 2019-03-21 01:25:00 UTC
Hi all!
After the latest updates, when opening file (jpg or png), I get this error:

GIMP Message
Plug-in crashed: "file-jpeg"
(/usr/local/libexec/gimp/2.2/plug-ins/file-jpeg/file-jpeg)

The dying plug-in may have messed up GIMP's internal state. You may want to save your images and restart GIMP to be on the safe side.

Procedure 'file-jpeg-load' returned no return values

Console log:
admin@vladiom:~ % gimp
/usr/local/libexec/gimp/2.2/plug-ins/file-jpeg/file-jpeg: fatal error: Abort trap
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error

GIMP with all dependencies was reinstalled twice!

root@vladiom:~ # pkg version -v | grep gimp
en-gimp-help-html-2.8.2_1          =   up-to-date with index
gimp-2.10.8,2                      =   up-to-date with index
gimp-app-2.10.8_1,1                =   up-to-date with index
gimp-gmic-plugin-1.6.9_19          =   up-to-date with index
gimp-gutenprint-5.2.14             =   up-to-date with index
gimp-resynthesizer-2.0.3           =   up-to-date with index
gimp-save-for-web-0.29.3_4         =   up-to-date with index
py27-gimp-2.10.8_1                 =   up-to-date with index
ru-gimp-help-html-2.8.2_1          =   up-to-date with index

root@vladiom:~ # uname -srm
FreeBSD 11.2-RELEASE-p9 amd64
Comment 1 tjlegg 2019-03-21 03:03:17 UTC
(In reply to Vladimir Omelchuk from comment #0)
Have you updated to exiv2 version 0.27.0?

https://gitlab.gnome.org/GNOME/gimp/issues/2703

https://gitlab.gnome.org/GNOME/gexiv2/issues/27
Comment 2 Vladimir Omelchuk 2019-03-21 03:06:52 UTC
(In reply to tjlegg from comment #1)

Of course!

root@vladiom:~ # pkg version -v | grep exiv
exiv2-0.27.0,1                     =   up-to-date with index
gexiv2-0.10.9_3                    =   up-to-date with index
libkexiv2-18.12.3_2                =   up-to-date with index
Comment 3 Stefan Ehmann 2019-03-23 08:23:16 UTC
Can confirm that exiv2 upgrade is the problem.
After downgrade to exiv2-0.26_1,1 gimp is working again.
Comment 4 Vladimir Omelchuk 2019-03-23 16:00:10 UTC
(In reply to Stefan Ehmann from comment #3)

Yes, after downgrade ports exiv2 and gexiv2, and rebuild GIMP,
GIMP work is fine!!!

root@vladiom:~ # pkg version -v | grep exiv
exiv2-0.26_1,1                     <   needs updating (index has 0.27.0,1)
gexiv2-0.10.9_1                    <   needs updating (index has 0.10.9_3)
libkexiv2-18.12.3_2                =   up-to-date with index
Comment 5 Stefan Ehmann 2019-03-25 20:36:25 UTC
Created attachment 203148 [details]
patch disabling -fvisibility=hidden

This seems to be a problem with -fvisibility=hidden. The attached patch restores the behavior of 0.26, i.e., all symbols are public.

Maybe there's a cleaner fix that works with hidden visibility but I gave up for now.

Upstream, there was a similar fix for MacOS:
https://github.com/Exiv2/exiv2/commit/e4301637bcd12fa51433dc60368196c04f267de8#diff-410e5c2117ab5cf5568b441bac6140d4
Comment 6 lumiwa 2019-03-25 22:30:57 UTC
As I understand corect the problem is not in GIMP but update of exiv2 which make GIMP unusable without downgrade?
Comment 7 gja822 2019-03-26 17:10:40 UTC
Very likely the same problem is with graphics/cinepaint
Comment 8 gja822 2019-03-27 04:48:02 UTC
(In reply to gja822 from comment #7)
Proposed patch worked for me for graphics/gimp to open JPEG and PNG etc. files.
It happen that graphics/cinepaint has somewhat different problem, I was wrong. For me it do not open only PNG files (JPEG and TIFF work fine).


png.c:139
/usr/local/lib/cinepaint/1.0-4/plug-ins/png
wire_write: write error 2

** (process:8637): ERROR (recursed) **: ERROR: gp_proc_run_write failedwire_read: unexpected EOF (plug-in crashed?)
Comment 10 Stefan Ehmann 2019-03-27 18:37:57 UTC
(In reply to Tobias C. Berner from comment #9)

Couldn't get the macports-ports patch to work. That's why I posted the visibility-patch.

gimp is somewhat hard to debug, there is a small test program in this comment:
https://gitlab.gnome.org/GNOME/gexiv2/issues/27#note_403221
Comment 11 commit-hook freebsd_committer 2019-03-29 19:08:07 UTC
A commit references this bug:

Author: tcberner
Date: Fri Mar 29 19:07:32 UTC 2019
New revision: 497188
URL: https://svnweb.freebsd.org/changeset/ports/497188

Log:
  graphics/exiv2: add patch to fix gimp

  Modify upstrams fix [1] for FreeBSD.

  PR:		236677
  Reported by:	Vladimir Omelchuk <admin@vladiom.com.ua>

Changes:
  head/graphics/exiv2/Makefile
  head/graphics/exiv2/files/
  head/graphics/exiv2/files/patch-git_04c9b1
  head/graphics/gexiv2/Makefile
  head/graphics/gimp-app/Makefile
Comment 12 Tobias C. Berner freebsd_committer 2019-03-29 19:28:51 UTC
Should be working now. Sorry for the breakage.


[1] https://github.com/Exiv2/exiv2/commit/04c9b181cc2c7741fcb134ccc43f2bafc1f86f19
Comment 13 Vladimir Omelchuk 2019-03-29 22:30:19 UTC
(In reply to Tobias C. Berner from comment #12)

Now GIMP is working correctly!
Thanks!
Comment 14 lumiwa 2019-07-13 09:26:30 UTC
Now on the GIMP 2.10.12 is the same problem.
Comment 15 Tobias C. Berner freebsd_committer 2019-07-13 09:35:50 UTC
Created attachment 205746 [details]
v1

Moin moin

could you rebuild exiv2 with the attached patch (and probably gimp also).


mfg Tobias
Comment 16 commit-hook freebsd_committer 2019-07-13 15:53:08 UTC
A commit references this bug:

Author: tcberner
Date: Sat Jul 13 15:52:17 UTC 2019
New revision: 506546
URL: https://svnweb.freebsd.org/changeset/ports/506546

Log:
  graphics/exiv2: readd visibility patch for graphics/gimp

  PR:		236677
  Reported by:	 lumiwa@gmail.com, starikarp@dismail.de

Changes:
  head/graphics/exiv2/Makefile
  head/graphics/exiv2/files/
  head/graphics/exiv2/files/patch-cmake_mainSetup.cmake
  head/graphics/gimp/Makefile