Bug 236704 - emulators/vice: fix build with GCC-based architectures
Summary: emulators/vice: fix build with GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-21 13:20 UTC by Piotr Kubaj
Modified: 2019-05-10 15:38 UTC (History)
2 users (show)

See Also:
dinoex: maintainer-feedback+


Attachments
patch (826 bytes, patch)
2019-03-21 13:20 UTC, Piotr Kubaj
no flags Details | Diff
patch (899 bytes, patch)
2019-04-02 11:16 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-03-21 13:20:58 UTC
Created attachment 203032 [details]
patch

FreeBSD/powerpc* need to include machine/pio.h and sys/types.h in src/iodrv/io-unix-access.c to build this port.

Additionally, sort USES and add USES=gl gnome sdl.

Tested on powerpc64 and amd64.

Hardware sponsored by IntegriCloud.
Comment 1 Dirk Meyer freebsd_committer 2019-03-24 20:13:02 UTC
rejected, please do not sort USES alphabetically.
Comment 2 Dirk Meyer freebsd_committer 2019-03-24 20:27:20 UTC
It looks wrong to add USES=SDL for GTK3GUI.

It looks wrong to add USES=gnome for SDLGUI.
Comment 3 commit-hook freebsd_committer 2019-03-25 08:44:05 UTC
A commit references this bug:

Author: dinoex
Date: Mon Mar 25 08:43:38 UTC 2019
New revision: 496803
URL: https://svnweb.freebsd.org/changeset/ports/496803

Log:
  - add USES localbase:ldflags
  PR:		236704

Changes:
  head/emulators/vice/Makefile
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2019-03-27 11:52:37 UTC
(In reply to Dirk Meyer from comment #1)

> please do not sort USES alphabetically.

Why?  This is the recommendation of portlint.  AFAIK there is no reason not to follow it; if there is, we need to find out what code in bsd.*.mk is preventing it, and fix both that and portlint.
Comment 5 Dirk Meyer freebsd_committer 2019-03-30 10:02:58 UTC
In some cases the order of the USES is important,
as some USES depend on macros defined by on other USES.

This is not fixable in the current framework.

Please fix portlint.


The suggested patch brings regressions and unneeded dependencies.

global USES is wrong, as the usage depends on the option selected.
Comment 6 Piotr Kubaj freebsd_committer 2019-04-02 11:16:48 UTC
Created attachment 203316 [details]
patch

It looks like I forgot to svn add this patch. Can you commit it? It fixes compilation with GCC.
Comment 7 Piotr Kubaj freebsd_committer 2019-04-02 11:17:16 UTC
Opening.
Comment 8 commit-hook freebsd_committer 2019-05-10 15:30:58 UTC
A commit references this bug:

Author: dinoex
Date: Fri May 10 15:30:12 UTC 2019
New revision: 501180
URL: https://svnweb.freebsd.org/changeset/ports/501180

Log:
  - fix build with GCC-based architectures
  PR:		236704
  Submitted by:	Piotr Kubaj

Changes:
  head/emulators/vice/Makefile
  head/emulators/vice/files/patch-src_iodrv_io-unix-access.c