Bug 236803 - x11-servers/xorg-server: X crashes on some Intel based hardware
Summary: x11-servers/xorg-server: X crashes on some Intel based hardware
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-26 14:34 UTC by c0141
Modified: 2020-04-15 20:11 UTC (History)
2 users (show)

See Also:


Attachments
X backtrace (4.34 KB, text/plain)
2019-03-26 14:34 UTC, c0141
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description c0141 2019-03-26 14:34:12 UTC
Created attachment 203161 [details]
X backtrace

On my Lenovo T430 and X230 X started crashing in February. It happens when I use mupdf of firefox. So to test install mupdf and open any pdf file.

It seems something changed in either xorg-server or some related GL library or perhaps in the i915kms module.
I have to beadm environments. 
First one where X does not crash:
xorg-server-1.18.4_10,1 and mesa-dri-18.1.9_2 
second one where X crashes:
xorg-server-1.18.4_11,1 and mesa-dri-18.3.2

The X230 has a Intel Core i7-3520M CPU @ 2.90GHz. The T430 has a Intel Core i5-3320M CPU @ 2.60GHz.

OS: FreeBSD 11.2-p9 or FreeBSD 12
Always AMD64.

I am adding an attachment with backtrace from X. I may be able to compile X or other ports with debug info if that helps.

The crash can be avoided by creating a xorg.conf configuration file in /etc/X11 with the following under Section "Device"

  Option "AccelMethod" "sna" 

It seems this also happens on some versions of Linux on the same hardware but I have not tested this.

I do not see the crash on my Intel NUC which has a Intel Core(TM) i5-4250U CPU @ 1.30GHz.
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-03-26 15:05:32 UTC
possible duplicate of bug #235487.
Comment 2 Niclas Zeising freebsd_committer 2019-07-29 12:44:43 UTC
Is this still an issue, even with updated graphics drivers?
Comment 3 Niclas Zeising freebsd_committer 2020-04-15 20:11:19 UTC
Feedback timeout