Bug 236823 - editors/libreoffice: fix build with GCC-based architectures
Summary: editors/libreoffice: fix build with GCC-based architectures
Status: Closed DUPLICATE of bug 236765
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-27 07:29 UTC by Piotr Kubaj
Modified: 2019-03-27 07:34 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments
patch (1.41 KB, patch)
2019-03-27 07:29 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-03-27 07:29:50 UTC
Created attachment 203180 [details]
patch

GCC currently doesn't know about some E* macros for errors. Make them ifdef'd. Additionally, remove check for ETIMEDOUT, which is apparently the same value as ETIME (this also causes an error).

Tested on powerpc64 and amd64.
Comment 1 Li-Wen Hsu freebsd_committer 2019-03-27 07:34:02 UTC
Thanks for the patch, I'm testing the one in 236765 and will commit along with other fixes.

*** This bug has been marked as a duplicate of bug 236765 ***