Bug 236860 - devel/icu: fix build on big-endian platforms
Summary: devel/icu: fix build on big-endian platforms
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-office mailing list
URL:
Keywords:
Depends on:
Blocks: 236325
  Show dependency treegraph
 
Reported: 2019-03-28 19:59 UTC by Piotr Kubaj
Modified: 2019-04-13 07:27 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments
patch (1.41 KB, patch)
2019-03-28 19:59 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-03-28 19:59:51 UTC
Created attachment 203221 [details]
patch

ICU 64.1 seems to have broken build on big-endian platforms. However, building from Github's tarball works just fine. Upon closer investigation, it looks like the tarball from ICU's website has some files pre-generated, but only for little-endian. Switch to Github to fix build.
Comment 1 Chip Cuccio 2019-03-29 13:07:40 UTC
Thank you for the patch and the work on this...

I can confirm, that the attached patch fixes the build issue I've been experiencing on powerpc arch since the port was updated on March 27, 2019.

Cheers.
Comment 2 Jan Beich freebsd_committer 2019-03-29 17:18:27 UTC
Can you report upstream (quoting actual error message)? The port uses release distfile per portmgr@ request in bug 232300 comment 2.

Sorry, I can't file a bug on your behalf because upstream uses Jira which requires Atlassian account which is unfriendly to Tor users: "Failure processing signup routes request." Maybe office@ peers can help instead.

> DISTVERSION=	64_1
...
>+GH_TAGNAME=	release-${DISTVERSION:S/_/-/}

Better re-apply ports r482186 i.e., convert the above to

  DISTVERSION=	64-1
  ...
  DISTVERSIONPREFIX=	release-
Comment 3 Steve Wills freebsd_committer 2019-04-10 20:10:55 UTC
(In reply to Jan Beich from comment #2)
It's fine to use the github archive.
Comment 4 commit-hook freebsd_committer 2019-04-12 22:36:14 UTC
A commit references this bug:

Author: jbeich
Date: Fri Apr 12 22:35:16 UTC 2019
New revision: 498770
URL: https://svnweb.freebsd.org/changeset/ports/498770

Log:
  devel/icu: unbreak on big-endian after r496981

  gmake[2]: *** No rule to make target 'out', needed by 'out/icudt64b.dat'.  Stop.
  gmake[2]: Leaving directory '/usr/ports/devel/icu/work/icu/source/data'

  PR:		236860
  Reported by:	Piotr Kubaj, pkg-fallout
  Obtained from:	Gentoo

Changes:
  head/devel/icu/files/patch-data_Makefile.in
Comment 5 commit-hook freebsd_committer 2019-04-12 22:36:17 UTC
A commit references this bug:

Author: jbeich
Date: Fri Apr 12 22:35:40 UTC 2019
New revision: 498771
URL: https://svnweb.freebsd.org/changeset/ports/498771

Log:
  MFH: r498770

  devel/icu: unbreak on big-endian after r496981

  gmake[2]: *** No rule to make target 'out', needed by 'out/icudt64b.dat'.  Stop.
  gmake[2]: Leaving directory '/usr/ports/devel/icu/work/icu/source/data'

  PR:		236860
  Reported by:	Piotr Kubaj, pkg-fallout
  Obtained from:	Gentoo
  Approved by:	ports-secteam blanket

Changes:
_U  branches/2019Q2/
  branches/2019Q2/devel/icu/files/patch-data_Makefile.in