Bug 236879 - [PATCH] cad/lepton-eda: fix build on 13.0-CURRENT
Summary: [PATCH] cad/lepton-eda: fix build on 13.0-CURRENT
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-29 13:38 UTC by dmn
Modified: 2019-04-17 05:58 UTC (History)
2 users (show)

See Also:


Attachments
patch for cad/lepton-eda 1.9.7 port's Makefile (445 bytes, patch)
2019-03-29 13:38 UTC, dmn
no flags Details | Diff
patch for cad/lepton-eda 1.9.7 that fixes link errors on 13.0-CURRENT (370 bytes, patch)
2019-03-30 13:13 UTC, dmn
no flags Details | Diff
patch for cad/lepton-eda 1.9.7 that fixes link errors on 13.0-CURRENT (1020 bytes, patch)
2019-04-05 06:30 UTC, dmn
no flags Details | Diff
cad/lepton-eda: fix link errors in utils/gschlas on 13.0-CURRENT (2.00 KB, patch)
2019-04-05 13:43 UTC, dmn
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description dmn 2019-03-29 13:38:58 UTC
Created attachment 203242 [details]
patch for cad/lepton-eda 1.9.7 port's Makefile

Add glib20 to USE_GNOME.
Comment 1 Steve Wills freebsd_committer 2019-03-29 16:36:44 UTC
Didn't fix the build on CURRENT for me:

ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_get_parse_name
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_parse_name
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_io_error_quark
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_equal
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_get_child
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_get_parent
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_get_path
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_get_type
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_hash
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_load_contents
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_make_directory_with_parents
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_new_for_path
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_query_exists
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_query_file_type
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_file_replace_contents
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_input_stream_get_type
ld: error: ../../liblepton/src/.libs/liblepton.so: undefined reference to g_memory_input_stream_new_from_data
Comment 2 dmn 2019-03-30 13:13:34 UTC
Created attachment 203256 [details]
patch for cad/lepton-eda 1.9.7 that fixes link errors on 13.0-CURRENT

As it turned out, utils/gschlas fails to link with new ld.lld linker
(the default one on CURRENT) for some reason. I'm still investigating this.
The walk-around is to add LLD_UNSAFE=yes to the Makefile (this pulls in
devel/binutils).
Checked on 13.0-CURRENT r345620 amd64, and it works.
Comment 3 dmn 2019-04-05 06:30:20 UTC
Created attachment 203396 [details]
patch for cad/lepton-eda 1.9.7 that fixes link errors on 13.0-CURRENT

Make portlint happy. The only warning left is this:

"WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy."

But this warning is issued for ALL ports. Maybe a bug in portlint.
It also doesn't ignore comments in makefile, I suppose that it is
a portlint bug, too.
Comment 4 dmn 2019-04-05 13:43:03 UTC
Created attachment 203410 [details]
cad/lepton-eda: fix link errors in utils/gschlas on 13.0-CURRENT

Finally I found the root cause of those link errors.
Added patch file for utils/gschlas/Makefile.am.
Comment 5 Kurt Jaeger freebsd_committer 2019-04-17 05:25:47 UTC
testbuilds@work
Comment 6 Kurt Jaeger freebsd_committer 2019-04-17 05:58:06 UTC
Committed, thanks!
Comment 7 commit-hook freebsd_committer 2019-04-17 05:58:29 UTC
A commit references this bug:

Author: pi
Date: Wed Apr 17 05:58:06 UTC 2019
New revision: 499146
URL: https://svnweb.freebsd.org/changeset/ports/499146

Log:
  cad/lepton-eda: fix build on 13.0-CURRENT

  PR:		236879
  Submitted by:	graahnul.grom@gmail.com (maintainer)

Changes:
  head/cad/lepton-eda/Makefile
  head/cad/lepton-eda/files/patch-utils_gschlas_Makefile.am