Bug 236886 - Chelsio T520-BT NIC not detected
Summary: Chelsio T520-BT NIC not detected
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.0-STABLE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-29 17:47 UTC by peos42
Modified: 2019-03-29 19:05 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peos42 2019-03-29 17:47:35 UTC
Hi

I just replaced an intel NIC with a new Chelsio T520-BT card. The FreeBSD 12.0p3 does not find a driver at all for it.

I had the impression that the driver was included in FreeBSD. So they say at Chelsio.

Advice?

/Peo
Comment 1 peos42 2019-03-29 17:54:28 UTC
Pci output

none53@pci0:4:0:0:	class=0x020000 card=0x00001425 chip=0x50091425 rev=0x00 hdr=0x00
    vendor     = 'Chelsio Communications Inc'
    device     = 'T520-BT Unified Wire Ethernet Controller'
    class      = network
    subclass   = ethernet
none54@pci0:4:0:1:	class=0x020000 card=0x00001425 chip=0x50091425 rev=0x00 hdr=0x00
    vendor     = 'Chelsio Communications Inc'
    device     = 'T520-BT Unified Wire Ethernet Controller'
    class      = network
    subclass   = ethernet
none55@pci0:4:0:2:	class=0x020000 card=0x00001425 chip=0x50091425 rev=0x00 hdr=0x00
    vendor     = 'Chelsio Communications Inc'
    device     = 'T520-BT Unified Wire Ethernet Controller'
    class      = network
    subclass   = ethernet
none56@pci0:4:0:3:	class=0x020000 card=0x00001425 chip=0x50091425 rev=0x00 hdr=0x00
    vendor     = 'Chelsio Communications Inc'
    device     = 'T520-BT Unified Wire Ethernet Controller'
    class      = network
    subclass   = ethernet
none57@pci0:4:0:4:	class=0x020000 card=0x00001425 chip=0x54091425 rev=0x00 hdr=0x00
    vendor     = 'Chelsio Communications Inc'
    device     = 'T520-BT Unified Wire Ethernet Controller'
    class      = network
    subclass   = ethernet
none58@pci0:4:0:5:	class=0x010000 card=0x00001425 chip=0x55091425 rev=0x00 hdr=0x00
    vendor     = 'Chelsio Communications Inc'
    device     = 'T520-BT Unified Wire Storage Controller'
    class      = mass storage
    subclass   = SCSI
none59@pci0:4:0:6:	class=0x0c0400 card=0x00001425 chip=0x56091425 rev=0x00 hdr=0x00
    vendor     = 'Chelsio Communications Inc'
    device     = 'T520-BT Unified Wire Storage Controller'
    class      = serial bus
    subclass   = Fibre Channel
Comment 2 peos42 2019-03-29 17:57:52 UTC
And a snippet from dmesg

pci0: <dasp, performance counters> at device 11.1 (no driver attached)
pci0: <dasp, performance counters> at device 11.2 (no driver attached)
pci0: <dasp, performance counters> at device 16.1 (no driver attached)
pci0: <dasp, performance counters> at device 16.6 (no driver attached)
pci0: <dasp, performance counters> at device 18.1 (no driver attached)
Comment 3 Navdeep Parhar freebsd_committer 2019-03-29 18:09:21 UTC
Is the driver loaded?  Note that cxgbe is _not_ compiled into GENERIC so you'll
have to load the module.  Add if_cxgbe to kld_list in rc.conf if you'd like to
load it when the system starts.

Try it manually for now and provide the output of dmesg | egrep 't5nex|cxl'
if it still doesn't work after the kldload.

# kldload if_cxgbe
Comment 4 peos42 2019-03-29 18:28:17 UTC
I forced a kldload /boot/kernel/if_cxgbe.ko and it said it updaed the crd firmware from  1.15.37.0 to  1.19.1.0 and it started to work.

But...

After a reboot I have to manually load the kernel module. Why?
Comment 5 Navdeep Parhar freebsd_committer 2019-03-29 18:34:19 UTC
(In reply to peos42 from comment #4)
> After a reboot I have to manually load the kernel module. Why?

You shouldn't have to.  You can autoload it from loader.conf (not recommended
unless you need the driver very early for netboot type stuff) or from rc.conf.

Add this to /etc/rc.conf:
kld_list="if_cxgbe"
If you have a kld_list alredy, add if_cxgbe to the existing list.

Or use ifconfig_cxl<n>=... commands in rc.conf as usual.  ifconfig will
autoload the driver for you.
Comment 6 Conrad Meyer freebsd_committer 2019-03-29 19:01:07 UTC
Something like https://reviews.freebsd.org/D19754 would load cxgbe.ko automatically on 12.x+ if the PCIID is detected (by devd).
Comment 7 peos42 2019-03-29 19:05:04 UTC
(In reply to Navdeep Parhar from comment #5)

Oohhh. It seems to be my bad here as I did not know this was not loaded by default. It works now as it should. Also, the man page say the same.

Thanks

And sorry I was to quick without the proper research...