Bug 236903 - security/opencryptoki: fix build with GCC-based architectures
Summary: security/opencryptoki: fix build with GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Sato
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-30 19:48 UTC by Piotr Kubaj
Modified: 2019-04-07 16:29 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments
patch (373 bytes, patch)
2019-03-30 19:48 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-03-30 19:48:29 UTC
Created attachment 203264 [details]
patch

Don't use GCC 4.2 on GCC architectures, this port requires at least GCC 4.7, so change USE_GCC=any to USE_GCC=yes.

Tested on powerpc64 and amd64.
Comment 1 commit-hook freebsd_committer 2019-04-07 16:25:56 UTC
A commit references this bug:

Author: linimon
Date: Sun Apr  7 16:24:56 UTC 2019
New revision: 498285
URL: https://svnweb.freebsd.org/changeset/ports/498285

Log:
  Don't use GCC 4.2 on GCC-based architectures; this port requires at
  least GCC 4.7, so change USE_GCC=any to USE_GCC=yes.

  PR:		236903
  Submitted by:	Piotr Kubaj
  Approved by:	portmgr (tier-2 blanket)

Changes:
  head/security/opencryptoki/Makefile
Comment 2 commit-hook freebsd_committer 2019-04-07 16:29:01 UTC
A commit references this bug:

Author: linimon
Date: Sun Apr  7 16:28:01 UTC 2019
New revision: 498286
URL: https://svnweb.freebsd.org/changeset/ports/498286

Log:
  MFH: r498285

  Don't use GCC 4.2 on GCC-based architectures; this port requires at
  least GCC 4.7, so change USE_GCC=any to USE_GCC=yes.

  PR:		236903
  Submitted by:	Piotr Kubaj
  Approved by:	portmgr (tier-2 blanket)

Changes:
_U  branches/2019Q2/
  branches/2019Q2/security/opencryptoki/Makefile