Bug 237017 - net-p2p/zetacoin: fails to build with boost 1.70
Summary: net-p2p/zetacoin: fails to build with boost 1.70
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords: needs-patch, regression
Depends on:
Blocks: 235956
  Show dependency treegraph
 
Reported: 2019-04-04 15:50 UTC by Jan Beich
Modified: 2019-09-14 14:27 UTC (History)
2 users (show)

See Also:
daniel: maintainer-feedback+


Attachments
Unified diff containing the described changes (28.38 KB, patch)
2019-07-18 01:20 UTC, Daniel Morante
daniel: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2019-04-04 15:50:04 UTC
While preparing for Boost upgrade this port failed to build. Can you help to avoid marking it as BROKEN?

$ fetch -qo- 'https://reviews.freebsd.org/D19303?download=true' |
  patch -Efsp0 -d /usr/ports
$ make all deinstall install clean -C/usr/ports/devel/boost-jam
$ make all deinstall install clean -C/usr/ports/devel/boost-libs
$ make -C/usr/ports/net-p2p/zetacoin
[...]
rpcserver.cpp:511:111: error: no member named 'get_io_service' in 'boost::asio::basic_socket_acceptor<boost::asio::ip::tcp, boost::asio::executor>'
    boost::shared_ptr< AcceptedConnectionImpl<Protocol> > conn(new AcceptedConnectionImpl<Protocol>(acceptor->get_io_service(), context, fUseSSL));
                                                                                                    ~~~~~~~~  ^
rpcserver.cpp:702:13: note: in instantiation of function template specialization 'RPCListen<boost::asio::ip::tcp>' requested here
            RPCListen(acceptor, *rpc_ssl_context, fUseSSL);
            ^
1 error generated.
Comment 1 Daniel Morante 2019-04-07 21:37:12 UTC
I'll update this to the latest upstream to see if that solves the problem.
Comment 2 Jan Beich freebsd_committer 2019-04-12 09:44:14 UTC
The port has been marked BROKEN in ports r498698.
Comment 3 Daniel Morante 2019-07-17 16:01:24 UTC
Currently running build tests on the updated port.  I'll post the patch once those pass.
Comment 4 Daniel Morante 2019-07-18 01:20:54 UTC
Created attachment 205856 [details]
Unified diff containing the described changes

Updated Zetacoin to 0.13.2.1 and refactored the port to align with the style used in net-p2p/bitcoin.  

Summary of changes:

- Renamed slave port net-p2p/netacoin-nox11 to net-p2p/zetacoin-daemon.
- The zetacoin-cli and zetacoin-tx utilities have been re-packaged into
  a separate port: net-p2p/zetacoin-utils

Build tests passed on 11.2 and 12.0 (amd63 and i386) using poudriere.

SVN commands that were used:

svnlite remove net-p2p/zetacoin/files/patch-src_bitcoin-cli.cpp 
svnlite remove net-p2p/zetacoin/files/patch-src_rpcserver.cpp 
svnlite remove net-p2p/zetacoin/pkg-plist 
svnlite move net-p2p/zetacoin/files/zetacoin.conf.sample files/zetacoin.conf
svnlite add net-p2p/zetacoin/files/patch-src_Makefile.bench.include 
svnlite add net-p2p/zetacoin/files/patch-src_miner.h 
svnlite add net-p2p/zetacoin/files/patch-src_txmempool.h
svnlite add net-p2p/zetacoin/files/zetacoin-qt.desktop 
svnlite add net-p2p/zetacoin/pkg-help 
svnlite add net-p2p/zetacoin-daemon
svnlite add net-p2p/zetacoin-utils
Comment 5 Rene Ladan freebsd_committer 2019-09-14 13:58:46 UTC
Some comments:
- I moved some USES=qt:5 into the SLAVE=no code, as only the main port uses QT
- The daemon port is currently broken because it references the no-longer existing zetacoin.conf, I have removed those lines for now.
Comment 6 Rene Ladan freebsd_committer 2019-09-14 14:03:53 UTC
(In reply to Rene Ladan from comment #5)
Ah, so somehow renaming zetacoin.conf.sample to zetacoin.conf failed.
Comment 7 commit-hook freebsd_committer 2019-09-14 14:26:54 UTC
A commit references this bug:

Author: rene
Date: Sat Sep 14 14:26:34 UTC 2019
New revision: 512017
URL: https://svnweb.freebsd.org/changeset/ports/512017

Log:
  net-p2p/zetacoin: fix build with current boost.

  Resurrect -nox11 slave port as -daemon slave port.
  Split off cli and tx utilities from main port into -utils slave port.

  PR:		237017
  Submitted by:	Daniel Morante
  Reported by:	jbeich

Changes:
  head/MOVED
  head/UPDATING
  head/net-p2p/Makefile
  head/net-p2p/zetacoin/Makefile
  head/net-p2p/zetacoin/distinfo
  head/net-p2p/zetacoin/files/patch-src_Makefile.bench.include
  head/net-p2p/zetacoin/files/patch-src_bitcoin-cli.cpp
  head/net-p2p/zetacoin/files/patch-src_miner.h
  head/net-p2p/zetacoin/files/patch-src_rpcserver.cpp
  head/net-p2p/zetacoin/files/patch-src_txmempool.h
  head/net-p2p/zetacoin/files/zetacoin-qt.desktop
  head/net-p2p/zetacoin/files/zetacoin.conf
  head/net-p2p/zetacoin/files/zetacoin.conf.sample
  head/net-p2p/zetacoin/files/zetacoin.in
  head/net-p2p/zetacoin/pkg-help
  head/net-p2p/zetacoin/pkg-plist
  head/net-p2p/zetacoin-daemon/
  head/net-p2p/zetacoin-daemon/Makefile
  head/net-p2p/zetacoin-utils/
  head/net-p2p/zetacoin-utils/Makefile
Comment 8 Rene Ladan freebsd_committer 2019-09-14 14:27:46 UTC
Patch committed, thanks.