Bug 237300 - net/libdnet: Fails to configure: No suitable firewall interface found
Summary: net/libdnet: Fails to configure: No suitable firewall interface found
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rodrigo Osorio
URL:
Keywords: needs-patch, needs-qa
: 237301 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-15 13:03 UTC by oz42
Modified: 2019-06-14 11:15 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (onatan)
koobs: merge-quarterly?


Attachments
config.log (113.64 KB, text/plain)
2019-04-15 13:03 UTC, oz42
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description oz42 2019-04-15 13:03:52 UTC
Created attachment 203695 [details]
config.log

config.log attached. Build output:

checking for Berkeley Packet Filter... yes
checking for raw IP sockets ip_{len,off} host byte ordering... yes
|------------------------------------------|
|No suitable firewall interface found. Most|
|probably you are not running the FreeBSD  |
|OS. Please consider using this version    |
|of libdnet  with the FreeBSD system       |
|------------------------------------------|
===>  Script "configure" failed unexpectedly.
Comment 1 Koichiro Iwao freebsd_committer 2019-04-15 13:16:12 UTC
*** Bug 237301 has been marked as a duplicate of this bug. ***
Comment 2 Dirk Meyer freebsd_committer 2019-04-27 06:23:44 UTC
It fails to build in a jail:

checking for Berkeley Packet Filter... no
checking for raw IP sockets ip_{len,off} host byte ordering... yes
|------------------------------------------|
|No suitable Ethernet interface found. Most|
|probably you are not running the FreeBSD  |
|OS. Please consider using this version    |
|of libdnet  with the FreeBSD system       |
|------------------------------------------|
===>  Script "configure" failed unexpectedly.
Comment 3 Rodrigo Osorio freebsd_committer 2019-04-30 12:38:53 UTC
Can you provide more informations about the way you are building this port ?

Poudriere build with FreeBSD12 works as expected.
Comment 4 Dirk Meyer freebsd_committer 2019-05-02 15:29:48 UTC
(In reply to Rodrigo Osorio from comment #3)

clean jail with standard devfs

/etc/make.conf
USE_PACKAGE_DEPENDS=yes

cd /usr/ports/net/libdnet && make package

Reason to build:
net/libdnet is now needed as a dependency for emulators/open-vm-tools-nox11
Comment 5 Rodrigo Osorio freebsd_committer 2019-05-30 11:36:16 UTC
The failure was caused because your jail doesn't expose the required devfs devices; in that case /dev/bpf.

You can solve the problem by creating a /etc/devfs.rules file in the host, and add the following lines :

[devfsrules_jail=4]
add include $devfsrules_hide_all
add include $devfsrules_unhide_basic
add include $devfsrules_unhide_login
add path fuse unhide
add path zfs unhide
add path 'bpf*' unhide

This is a copy of the /etc/default/devfs.rules with an extra line to allow bpf devices.

Now you can restart your jail, see if the /dev/bpf is available and build your port again. The error was caused by a failed test during the configure step (take a look in the configure file at line 17256 who set ac_cv_dnet_bsd_bpf to false.

Later in line 17311, the variable is tested, and the error message displayed.

I consider this issue solved, but I will wait for your feedback to close it.
Please test and le me know if it's ok for you.

Cheers,
-- rodrigo
Comment 6 Rodrigo Osorio freebsd_committer 2019-06-14 11:15:00 UTC
reporter time-out