Bug 237565 - audio/caps-lv2: fix build with GCC-based architectures
Summary: audio/caps-lv2: fix build with GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-25 16:57 UTC by Piotr Kubaj
Modified: 2019-04-25 17:08 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments
patch (406 bytes, patch)
2019-04-25 16:57 UTC, Piotr Kubaj
pkubaj: maintainer-approval? (yuri)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-04-25 16:57:36 UTC
Created attachment 204015 [details]
patch

Adding -stdlib=libstdc++ breaks this port - the problem is that GCC doesn't understand -stdlib.
Comment 1 Yuri Victorovich freebsd_committer 2019-04-25 17:07:42 UTC
Committed, thanks!
Comment 2 commit-hook freebsd_committer 2019-04-25 17:08:05 UTC
A commit references this bug:

Author: yuri
Date: Thu Apr 25 17:07:33 UTC 2019
New revision: 500037
URL: https://svnweb.freebsd.org/changeset/ports/500037

Log:
  audio/caps-lv2: fix build with GCC-based architectures

  PR:		237565
  Submitted by:	pkubaj

Changes:
  head/audio/caps-lv2/Makefile