Bug 237571 - regression with commit r344894 for H5 based Allwinners
Summary: regression with commit r344894 for H5 based Allwinners
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: CURRENT
Hardware: arm Any
: --- Affects Only Me
Assignee: Emmanuel Vadot
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-26 06:59 UTC by Manuel Stühn
Modified: 2019-12-05 07:25 UTC (History)
0 users

See Also:


Attachments
Bootlog (5.89 KB, text/plain)
2019-04-26 06:59 UTC, Manuel Stühn
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Stühn 2019-04-26 06:59:28 UTC
Created attachment 204025 [details]
Bootlog

Commit r344894 introduced a driver for CCU DE2 hardware on Allwinner based devices. On the Allwinner Nanopi NEO2 it gets probed but fails to gather parent clock sources and panics (see attached log)

If the device is explicitly deactivated (add status = "disabled" in dts file) the boot continues.
Comment 1 commit-hook freebsd_committer 2019-04-27 14:57:26 UTC
A commit references this bug:

Author: manu
Date: Sat Apr 27 14:56:25 UTC 2019
New revision: 346788
URL: https://svnweb.freebsd.org/changeset/base/346788

Log:
  arm64: allwinner: ccu_de2: Remove H5 compatible

  We don't have the display engine driver commited in FreeBSD yet so it is
  useless to expose the clocks yet (and also it have not been tested on H5).

  Reported by:	Manuel St?hn (freebsdnewbie@freenet.de)
  PR:	 237571
  MFC after:	1 week

Changes:
  head/sys/arm/allwinner/clkng/ccu_de2.c
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2019-05-09 01:53:36 UTC
Assign to committer in case of possible MFC needed.
Comment 3 commit-hook freebsd_committer 2019-08-05 18:27:39 UTC
A commit references this bug:

Author: manu
Date: Mon Aug  5 18:27:28 UTC 2019
New revision: 350605
URL: https://svnweb.freebsd.org/changeset/base/350605

Log:
  MFC r346334, r346787-r346789, r347017

  r346334:
  arm: allwinner: Fix audio for Allwinner H3/H5

  Due to three conditions the codec driver for Allwinner A10/A20 and H3/H5 did not work properly here:

      Wrong bit position for the analog audio reset
      Hardware Reset of codec was not de-asserted correctly
      Linux DTS file did not contain the address of the analog register the way as the driver was expecting it.

  This patch proposes fixes for those three parts.

  Submitted by:	freebsdnewbie@freenet.de (Manuel St?hn)
  Differential Revision:	https://reviews.freebsd.org/D19910

  r346787:
  arm64: allwinner: Add compatible strings for clock devices used on both Allwinner H3 and H5

  Allwinner H3 and H5 share many internal components, that's why they can
  use the same drivers.
  This patch adds the compatible strings to enable clock drivers
  probing on Allwinner NanoPI NEO2 device.

  Tested on: NanoPi NEO2 (by submitter), OrangePi PC2 (by manu)
  Submitted by:	Manuel St?hn (freebsdnewbie@freenet.de)
  Differential Revision:	https://reviews.freebsd.org/D20069

  r346788:
  arm64: allwinner: ccu_de2: Remove H5 compatible

  We don't have the display engine driver commited in FreeBSD yet so it is
  useless to expose the clocks yet (and also it have not been tested on H5).

  Reported by:	Manuel St?hn (freebsdnewbie@freenet.de)
  PR:	 237571

  r346789:
  arm: allwinner: a10: Correct pin functions

  PB20 and PB21 alternate function 1 is i2c2 not i2c1

  Reported by:	Horiki Mori (yamori813@yahoo.co.jp)
  PR:	 237401

  r347017:
  arm64: Add support for NanoPI NEO2

  Add overlay files and activate devicetree file for NanoPi NEO2 featuring
  Allwinner H5 ARM64 core.
  To enable sound, dma and codec drivers are enabled for build.

  Submitted by:	Manuel St?hn (freebsdnewbie@freenet.de)
  Differential Revision:	https://reviews.freebsd.org/D20129

Changes:
_U  stable/12/
  stable/12/sys/arm/allwinner/a10/a10_padconf.c
  stable/12/sys/arm/allwinner/a10_codec.c
  stable/12/sys/arm/allwinner/aw_rtc.c
  stable/12/sys/arm/allwinner/aw_syscon.c
  stable/12/sys/arm/allwinner/clkng/ccu_de2.c
  stable/12/sys/arm64/conf/GENERIC
  stable/12/sys/conf/files.arm64
  stable/12/sys/dts/arm64/overlays/sun50i-h5-nanopi-neo2-opp.dtso
  stable/12/sys/dts/arm64/overlays/sun50i-h5-opp.dtso
  stable/12/sys/dts/arm64/overlays/sun50i-h5-sid.dtso
  stable/12/sys/dts/arm64/overlays/sun50i-h5-ths.dtso
  stable/12/sys/modules/dtb/allwinner/Makefile