Bug 237631 - Missing some pcap man pages
Summary: Missing some pcap man pages
Status: Closed Overcome By Events
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-28 21:52 UTC by bc979
Modified: 2019-05-27 23:47 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bc979 2019-04-28 21:52:22 UTC
11.2 contains man pages for pcap-filter and pcap-linktype in man7.  Those are missing in 10.2-RELEASE.  The other pcap man pages in man3 are present.  The man page for pcap-filter contains the only description of the filters used by tcpdump.

sermons# uname -a
FreeBSD sermons 11.2-RELEASE-p8 FreeBSD 11.2-RELEASE-p8 #0: Tue Jan  8 21:35:12 UTC 2019     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
sermons# ll /usr/share/man/man7/pcap*
-r--r--r--  1 root  wheel  9706 Oct 10  2016 pcap-filter.7.gz
-r--r--r--  1 root  wheel  1166 Oct 10  2016 pcap-linktype.7.gz


master% uname -a
FreeBSD master 12.0-RELEASE-p3 FreeBSD 12.0-RELEASE-p3 GENERIC  amd64
master% ll /usr/share/man/man7/pcap*
ls: No match.
Comment 1 bc979 2019-04-28 21:57:34 UTC
Should have included that master was running 11.2 before and then it was upgraded to 12.0-RELEASE using freebsd-update.  Master does not contain /usr/src, but sermons does if that makes any difference.
Comment 2 Andrew Stevenson 2019-05-27 22:03:01 UTC
This is a duplicate of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237893 - or rather it is a duplicate of this one but the other one has a patch now.
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2019-05-27 23:47:58 UTC
Obsoleted by PR 237893.