Bug 237650 - graphics/wayland: update to 1.17
Summary: graphics/wayland: update to 1.17
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords: patch
Depends on: 224226
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-29 17:05 UTC by Jan Beich
Modified: 2020-02-10 17:38 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2019-04-29 17:05:07 UTC
See review D20099 for the patch. This bug is for better visibility. Please, don't reply with empty promises to review.
Comment 1 Simon Ser 2019-06-18 20:19:46 UTC
Hi, any updates on this? I'd like to remove the workaround we have in place for FreeBSD's outdated libwayland.
Comment 2 Tobias Kortkamp freebsd_committer 2019-06-29 04:19:44 UTC
Can someone from x11@ give Jan approval to commit this?  I think this has been
open for way too long.
Comment 3 Niclas Zeising freebsd_committer 2019-06-29 08:34:14 UTC
I will have a look at this, but there are other things (mesa and xorg infrastructure) taht's above this on my todo.
Comment 4 Tobias Kortkamp freebsd_committer 2019-06-30 08:18:59 UTC
(In reply to Niclas Zeising from comment #3)
> I will have a look at this, but there are other things (mesa and xorg
> infrastructure) taht's above this on my todo.

What QA would you do and is there anything I can help with?
Comment 5 Niclas Zeising freebsd_committer 2019-07-07 16:17:48 UTC
I've added the update + a patch to use SHM_ANON instead of posix_fallocate(), since posix_fallocate() doesn't work with ZFS.
Comment 6 Tobias Kortkamp freebsd_committer 2019-08-30 08:58:43 UTC
Ping?

Still not sure what QA I should do if any.  This update has not caused any
problems for me on 13.0 for the last 2 months with Sway etc.
Comment 7 Jan Beich freebsd_committer 2019-08-31 20:57:37 UTC
comment 5 pushed https://github.com/FreeBSDDesktop/freebsd-ports/commit/689501412ec9 on the same bandwagon. x11/waybar seems to crash more often after that change but not like Waybar was very stable before. Other Wayland clients appear to work fine.

Does anyone see something similar?

  $ sway
  $ waybar
  **
  GLib-GIO:ERROR:giostream.c:255:g_io_stream_get_output_stream: assertion failed: (klass->get_output_stream != NULL)
  Process 89916 stopped
  * thread #3, name = 'waybar', stop reason = signal SIGABRT
      frame #0: 0x000000080122e5ca libc.so.7`__sys_thr_kill at thr_kill.S:4
  (lldb) bt
  * thread #3, name = 'waybar', stop reason = signal SIGABRT
    * frame #0: 0x000000080122e5ca libc.so.7`__sys_thr_kill at thr_kill.S:4
      frame #1: 0x000000080122df44 libc.so.7`__raise(s=6) at raise.c:52:10
      frame #2: 0x000000080118f6f9 libc.so.7`abort at abort.c:67:8
      frame #3: 0x000000080235cb56 libglib-2.0.so.0`g_assertion_message(domain="GLib-GIO", file="giostream.c", line=255, func="g_io_stream_get_output_stream", message="assertion failed: (klass->get_output_stream != NULL)") at gtestutils.c:2532:5
      frame #4: 0x000000080235cbd4 libglib-2.0.so.0`g_assertion_message_expr(domain="GLib-GIO", file="giostream.c", line=255, func="g_io_stream_get_output_stream", expr="klass->get_output_stream != NULL") at gtestutils.c:2555:3
      frame #5: 0x000000080211cf64 libgio-2.0.so.0`g_io_stream_get_output_stream(stream=0x000000080397aa20) at giostream.c:255:3
      frame #6: 0x000000080219838c libgio-2.0.so.0`_g_dbus_auth_run_client(auth=0x00000008038aa0a0, observer=0x0000000000000000, offered_capabilities=G_DBUS_CAPABILITY_FLAGS_UNIX_FD_PASSING, out_negotiated_capabilities=0x00000008038b7238, cancellable=0x00000008034a1c70, error=0x00000008038b71c8) at gdbusauth.c:616:9
      frame #7: 0x00000008021aca2c libgio-2.0.so.0`initable_init(initable=0x00000008038b7160, cancellable=0x00000008034a1c70, error=0x00007fffdfdfcf08) at gdbusconnection.c:2542:26
      frame #8: 0x0000000802116a35 libgio-2.0.so.0`g_initable_init(initable=0x00000008038b7160, cancellable=0x00000008034a1c70, error=0x00007fffdfdfcf08) at ginitable.c:128:10
      frame #9: 0x00000008020d5484 libgio-2.0.so.0`async_init_thread(task=0x0000000803851280, source_object=0x00000008038b7160, task_data=0x0000000000000000, cancellable=0x00000008034a1c70) at gasyncinitable.c:260:7
      frame #10: 0x000000080215cabe libgio-2.0.so.0`g_task_thread_pool_thread(thread_data=0x0000000803851280, pool_data=0x0000000000000000) at gtask.c:1331:3
      frame #11: 0x0000000802361aa7 libglib-2.0.so.0`g_thread_pool_thread_proxy(data=0x00000008038e5b00) at gthreadpool.c:307:15
      frame #12: 0x000000080236057d libglib-2.0.so.0`g_thread_proxy(data=0x0000000803903c50) at gthread.c:784:20
      frame #13: 0x000000080052a776 libthr.so.3`thread_start(curthread=0x000000080382a900) at thr_create.c:291:16
Comment 8 Jan Beich freebsd_committer 2019-08-31 23:23:46 UTC
Another victim: net/waypipe ca no longer forward EGL clients with SHM_ANON fix. I still need someone to confirm as my environment is too weird.
Comment 9 Niclas Zeising freebsd_committer 2019-09-04 08:42:44 UTC
(In reply to Jan Beich from comment #8)

Is this related to https://github.com/FreeBSDDesktop/kms-drm/issues/156 ?
Comment 10 Jan Beich freebsd_committer 2019-09-04 10:22:26 UTC
No. kms-drm#156 was filed a few days before coment 5.
Comment 11 Jan Beich freebsd_committer 2019-11-10 20:29:33 UTC
Hmm, I can't reproduce comment 7 and comment 8 anymore. No one else confirmed, so those could either be due to a -CURRENT bump, fixed by a dependency update, intermittent (e.g., related to libepoll-shim), specific to old kms-drm versions or a pilot error (optimizations, partial upgrade, etc).
Comment 12 Simon Ser 2020-01-14 10:46:33 UTC
Hi,

Any update on this? As a side note, 1.18 will be release soon: https://lists.freedesktop.org/archives/wayland-devel/2020-January/041128.html

Thanks
Comment 13 Tobias Kortkamp freebsd_committer 2020-01-27 16:29:05 UTC
Niclas, how do we proceed from here?  There has been a long silence from x11@.
Per comment #11, Jan no longer has the problem from comment #7, so I do not
think anything is really blocking this?  (In any case the SHM_ANON patch is
trivially revertable too if anyone runs into problems with it.)

Should we ask for an exp-run and then ship it?
Comment 14 Emmanuel Vadot freebsd_committer 2020-01-27 16:39:31 UTC
(In reply to Tobias Kortkamp from comment #13)
There is no need for an exp-run honestly.
I've said to Jan on saturday that I will commit after testing and I haven't had time to test for now.
If it's not commited tomorow I'll take an hour and test/commit.
Comment 15 Niclas Zeising freebsd_committer 2020-01-27 16:42:20 UTC
I'm working on it.  I got side tracked yesterday.
Comment 16 commit-hook freebsd_committer 2020-01-28 11:53:37 UTC
A commit references this bug:

Author: zeising
Date: Tue Jan 28 11:53:09 UTC 2020
New revision: 524473
URL: https://svnweb.freebsd.org/changeset/ports/524473

Log:
  graphics/wayland: Update to 1.17

  Update graphics/wayland to 1.17 [1]
  Add a patch to use shm_anon instead of posix_fallocate(), as the latter
  doesn't work on ZFS.  [2]

  PR:		237650 [1], 224226 [2]
  Submitted by:	jbeich [1], jbeich and Greg V [2] (original version)
  Reviewed by:	Greg V, manu
  Differential Revision:	https://reviews.freebsd.org/D20099

Changes:
  head/graphics/wayland/Makefile
  head/graphics/wayland/distinfo
  head/graphics/wayland/files/patch-Makefile.am
  head/graphics/wayland/files/patch-cursor_os-compatibility.c
  head/graphics/wayland/files/patch-tests_sanity-test.c
  head/graphics/wayland/files/patch-tests_test-runner.c
Comment 17 Niclas Zeising freebsd_committer 2020-01-28 12:11:22 UTC
Leave this open for a bit, just in case.
Comment 18 Tobias Kortkamp freebsd_committer 2020-01-28 13:11:54 UTC
Thank you.
Comment 19 Niclas Zeising freebsd_committer 2020-02-10 17:38:06 UTC
No reports of fallout, closing this.