Bug 237726 - www/apache24: enable MD in the default build
Summary: www/apache24: enable MD in the default build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jochen Neumeister
URL:
Keywords:
: 237727 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-03 11:34 UTC by Igor Galić
Modified: 2020-08-06 14:20 UTC (History)
4 users (show)

See Also:


Attachments
Add MD to MOST modules (1.19 KB, patch)
2019-05-03 18:15 UTC, Igor Galić
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Galić 2019-05-03 11:34:07 UTC
thanks to https://www.freshports.org/www/mod_md-devel/ i learned that mod_md-devel

DEPRECATED: Use the module that is shipped with Apache 2.4
Expired This port expired on: 2019-03-24

and was as such, removed from latest.
However, the apache24 package provided in latest, does *not* come with a mod_md module.
Comment 1 Kurt Jaeger freebsd_committer 2019-05-03 16:33:10 UTC
Please use

make config

the most recent apache24 port has the MD option. Select this option and everything should be fine.
Comment 2 Igor Galić 2019-05-03 17:02:14 UTC
I understand the consequence, and what i need to do, i just don't agree.
Closing the port, means that a *binary* package is gone.

From the closing message, it ~feels~ like you could just get away with installing a different binary package. But that is just a lie i wanted to believe.

downloading the ports tree, and rebuilding a package, is *vastly* different UX compared to … installing a package. Especially on my very cheap cloud VM.
Comment 3 Kurt Jaeger freebsd_committer 2019-05-03 17:18:17 UTC
Hmm, mod_md is part of apache since at least July 2018, I guess. I even think (might be wrong) that it's also part of the default build, so the generic
freebsd repo should have the package with mod_md -- is that not the case ?
Comment 4 Igor Galić 2019-05-03 17:50:41 UTC
root@webproxy:~ # freebsd-version
12.0-RELEASE-p3
root@webproxy:~ # pkg info apache24 
apache24-2.4.39
Name           : apache24
Version        : 2.4.39
Installed on   : Fri May  3 10:50:59 2019 UTC
Origin         : www/apache24
Architecture   : FreeBSD:12:amd64
Prefix         : /usr/local
…
        MD             : off
…

so, no
also, according to http://svn.freebsd.org/ports/head/www/apache24/Makefile.options

MOST_DISABLED_MODULES= \
	AUTHNZ_LDAP BROTLI IDENT LDAP LUA MD SOCACHE_DC SOCACHE_REDIS SUEXEC
Comment 5 Kurt Jaeger freebsd_committer 2019-05-03 17:54:37 UTC
Ok, I agree, this should be default in the generic repo
Comment 6 Igor Galić 2019-05-03 18:05:56 UTC
*** Bug 237727 has been marked as a duplicate of this bug. ***
Comment 7 Igor Galić 2019-05-03 18:15:21 UTC
Created attachment 204198 [details]
Add MD to MOST modules
Comment 8 Mike Selner 2020-07-19 20:33:29 UTC
Hello. Can this please get committed?  It would be very useful. I’d like to write a HowTo for Apache+MD on FreeBSD and this default with MD would help greatly. 
Thank You
Comment 9 Igor Galić 2020-07-19 20:56:14 UTC
oh wow, i can't believe it's been over a year now

then again, the only way i've gotten any of my ports bugs resolved so far, was by actively bugging people on IRC, and for inexplicable reasons i thought once the issue was understood, and assigned, it wound also get merged soon.
Comment 10 commit-hook freebsd_committer 2020-07-21 20:50:51 UTC
A commit references this bug:

Author: joneum
Date: Tue Jul 21 20:50:20 UTC 2020
New revision: 542789
URL: https://svnweb.freebsd.org/changeset/ports/542789

Log:
  enable MD as default

  PR:		237726
  Submitted by:	Igor Galic <me@igalic.co>
  Sponsored by:	Netzkommune GmbH

Changes:
  head/www/apache24/Makefile.options
Comment 11 Bernard Spil freebsd_committer 2020-08-06 13:26:22 UTC
Hi Igor, Kurt,

We tend to track upstream's default enabled and disabled modules.

From 2.4.46 configure --help output:
>  --enable-proxy-http2    HTTP/2 proxy module. This module requires a
>                          libnghttp2 installation. See --with-nghttp2 on how
>                          to manage non-standard locations. Also requires
>                          --enable-proxy.                                                                               
>  --enable-md             Managed Domain handling                                                                       
>  --enable-jansson-staticlib-deps                                                                                       
>                          link mod_md with dependencies of libjansson's static
>                          libraries (as indicated by "pkg-config --static").
>                          Must be specified in addition to --enable-md.

Default disabled modules are listed "--enable-*", default enabled modules are listed as "--disable-*"

In other news, I'm thinking about resurrecting mod_md (and mod_http2), sometimes you need a slightly newer version. They were removed after they were added to Apache.
Comment 12 Igor Galić 2020-08-06 14:20:43 UTC
let me reiterate the main reason for this bug's existence:

- a binary package existed
- that binary package was removed…
- with a message strongly implying one could simply install a different binary package to get back the same functionality
- that message was either a lie, or my interpretation was delusional

either way, there's a stark asymmetry when removing a binary package, and expecting users gain it back by rebuilding a port. it's an individualist solution to a systematic problem

you made a clear decision, based on existing guidelines, but you didn't consider all consequences
I'm trying to point out the consequences, and asking you to either reconsider your policy as to what should go into default enabled modules, based on this precedent
or to otherwise, as yourself suggest, publish (the dev version of) this module again as installable binary package