Bug 237932 - [exp-run] Update graphics/proj to 6.1.0
Summary: [exp-run] Update graphics/proj to 6.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Wen Heping
URL:
Keywords:
: 237969 (view as bug list)
Depends on:
Blocks: 237969
  Show dependency treegraph
 
Reported: 2019-05-17 00:11 UTC by wen
Modified: 2019-07-14 12:12 UTC (History)
7 users (show)

See Also:
bugzilla: maintainer-feedback? (fmysh)


Attachments
update to 6.1.0 (11.99 KB, text/plain)
2019-05-17 00:11 UTC, wen
no flags Details
Revised patch include fix build of converters/osm2pgsql (12.51 KB, text/plain)
2019-05-19 12:05 UTC, wen
no flags Details
Patch to update graphics/py-pyproj from 1.9.6 to 2.1.3 (2.50 KB, patch)
2019-05-20 21:05 UTC, Antoine Brodin
no flags Details | Diff
Update graphics/proj to 6.1.0 and graphics/py-pyproj to 2.1.3 (15.02 KB, patch)
2019-05-20 21:14 UTC, Antoine Brodin
no flags Details | Diff
patch-to-make-proj5-install-separately.patch (1.64 KB, patch)
2019-06-01 22:42 UTC, Yuri Victorovich
no flags Details | Diff
- Repocopy graphics/proj --> graphics/proj5 (2.65 KB, text/plain)
2019-06-03 02:13 UTC, wen
no flags Details
second patch to update proj to 6.1.0, fix some build (71.34 KB, text/plain)
2019-06-03 03:10 UTC, wen
no flags Details
new patch to update proj to 6.1.0 and fix some broken ports (71.34 KB, text/plain)
2019-06-03 13:26 UTC, Wen Heping
no flags Details
Patch to repocopy graphics/proj --> graphics/proj5 and fix depends of 3 ports (2.65 KB, text/plain)
2019-06-03 13:28 UTC, Wen Heping
no flags Details
patch to update proj to 6.1.0 (75.60 KB, text/plain)
2019-06-16 04:19 UTC, Wen Heping
no flags Details
Revised patch , fixed saga and libght (76.06 KB, text/plain)
2019-06-17 04:03 UTC, Wen Heping
no flags Details
Repocopy proj-->proj5 and fix 4 ports (3.29 KB, text/plain)
2019-06-17 04:05 UTC, Wen Heping
no flags Details
Revised patch, include saga fix (82.74 KB, text/plain)
2019-06-25 14:52 UTC, Wen Heping
no flags Details
Repocopy proj --> proj5, fix 3 ports (2.65 KB, text/plain)
2019-06-25 14:55 UTC, Wen Heping
no flags Details
Refresh the patch-20190626 (83.52 KB, text/plain)
2019-06-26 12:00 UTC, Wen Heping
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description wen 2019-05-17 00:11:59 UTC
Created attachment 204410 [details]
update to 6.1.0

- Update to 6.1.0
- Add missing DEPENDS
- Add TEST_TARGET
- Take maintainership
Comment 1 Rainer Hurling 2019-05-18 17:02:05 UTC
Hi Wen,

Many thanks for your patch to update graphics/proj to 6.1.0, really appreciated.

I just tried to rebuild my dependencies pf graphics/proj after updating to 6.1.0 and get the following failings for two ports:

# cd converters/osm2pgsql
# make
/[1/33] /usr/bin/c++  -DBOOST_TEST_DYN_LINK -DDEFAULT_STYLE=\"/usr/local/share/osm2pgsql/default.style\" -DFIXED_POINT -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0 -I. -I/usr/local/include/lua53 -isystem /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/contrib/libosmium -isystem /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/contrib/protozero/include -isystem /usr/local/include -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -O2 -pipe -fstack-protector-strong -fno-strict-aliasing   -Wall -std=c++11 -MD -MT CMakeFiles/osm2pgsql.dir/osm2pgsql.cpp.o -MF CMakeFiles/osm2pgsql.dir/osm2pgsql.cpp.o.d -o CMakeFiles/osm2pgsql.dir/osm2pgsql.cpp.o -c /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/osm2pgsql.cpp
FAILED: CMakeFiles/osm2pgsql.dir/osm2pgsql.cpp.o 
/usr/bin/c++  -DBOOST_TEST_DYN_LINK -DDEFAULT_STYLE=\"/usr/local/share/osm2pgsql/default.style\" -DFIXED_POINT -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0 -I. -I/usr/local/include/lua53 -isystem /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/contrib/libosmium -isystem /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/contrib/protozero/include -isystem /usr/local/include -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -O2 -pipe -fstack-protector-strong -fno-strict-aliasing   -Wall -std=c++11 -MD -MT CMakeFiles/osm2pgsql.dir/osm2pgsql.cpp.o -MF CMakeFiles/osm2pgsql.dir/osm2pgsql.cpp.o.d -o CMakeFiles/osm2pgsql.dir/osm2pgsql.cpp.o -c /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/osm2pgsql.cpp
In file included from /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/osm2pgsql.cpp:28:
In file included from /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/reprojection.hpp:13:
In file included from /usr/ports/converters/osm2pgsql/work/osm2pgsql-0.96.0/contrib/libosmium/osmium/geom/projection.hpp:50:
/usr/local/include/proj_api.h:37:2: error: 'To use the proj_api.h you must define the macro ACCEPT_USE_OF_DEPRECATED_PROJ_API_H'
#error 'To use the proj_api.h you must define the macro ACCEPT_USE_OF_DEPRECATED_PROJ_API_H'
 ^

It seems, that for osm2pgsql some investigation in using the macro 'ACCEPT_USE_OF_DEPRECATED_PROJ_API_H' is needed.



# cd graphics/py-pyproj
# make FLAVOR=py36
===>  Building for py36-pyproj-1.9.6
PROJ_DIR is set, using existing proj4 installation..
running build
running build_py
copying lib/pyproj/datadir.py -> build/lib.freebsd-13.0-CURRENT-amd64-3.6/pyproj
running build_ext
building 'pyproj._proj' extension
cc -DNDEBUG -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -fPIC -I/usr/local/include -I/usr/local/include/python3.6m -c _proj.c -o build/temp.freebsd-13.0-CURRENT-amd64-3.6/_proj.o
In file included from _proj.c:613:
/usr/local/include/proj_api.h:37:2: error: 'To use the proj_api.h you must define the macro
      ACCEPT_USE_OF_DEPRECATED_PROJ_API_H'
#error 'To use the proj_api.h you must define the macro ACCEPT_USE_OF_DEPRECATED_PROJ_API_H'
 ^

For graphics/py-pyproj, a new version 2.1.3 is present upstream[1]. I need py-pyproj as a dependency of graphics/qgis and therefore prepared a patch against version 1.9.6[2]. This version builds and installs fine, but only with graphics/proj >= 6.0.0 !!!.


[1] https://github.com/pyproj4/pyproj/releases
[2] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237969



BTW: Portlint complains a bit about your Makefile of graphics/proj, especially it wants no PORTEPOCH, founds a whitespace in line 18, and GNU_CONFIGURE should be seperated from the USES section:


--- Makefile.orig	2019-05-18 12:37:46.926223000 +0200
+++ Makefile	2019-05-18 18:48:58.315969000 +0200
@@ -3,7 +3,6 @@
 
 PORTNAME=	proj
 PORTVERSION=	6.1.0
-PORTEPOCH=	1
 CATEGORIES=	graphics geography
 MASTER_SITES=	https://download.osgeo.org/proj/
 DISTFILES=	${DISTNAME}${EXTRACT_SUFX} ${DATUM_GRID_FILES}
@@ -16,16 +15,17 @@
 LICENSE_FILE=	${WRKSRC}/COPYING
 
 LIB_DEPENDS=	libsqlite3.so:databases/sqlite3
- 
+
+USES=		compiler:c++11-lang gmake libtool pathfix pkgconfig
+USE_LDCONFIG=	yes
+
+GNU_CONFIGURE=	yes
+
 DATUM_GRID_FILES=	proj-datumgrid-1.8.zip \
 			proj-datumgrid-europe-1.3.zip \
 			proj-datumgrid-north-america-1.2.zip \
 			proj-datumgrid-oceania-1.0.zip \
 			proj-datumgrid-world-1.0.zip
-
-GNU_CONFIGURE=	yes
-USES=		compiler:c++11-lang gmake libtool pathfix pkgconfig
-USE_LDCONFIG=	yes
 
 FMAN1=	cs2cs.1 geod.1 proj.1
 FMAN3=	geodesic.3 pj_init.3
Comment 2 wen 2019-05-19 12:05:12 UTC
Created attachment 204467 [details]
Revised patch include fix build of converters/osm2pgsql

Revised patch include:
1) fix build of converters/osm2pgsql
2) pet portlint
Comment 3 wen 2019-05-19 12:08:22 UTC
(In reply to Rainer Hurling from comment #1)
Thank you Rainer, I revised Makefile to pet portlint.
But PORTEPOCH could not be removed.

wen
Comment 4 Antoine Brodin freebsd_committer 2019-05-20 21:04:52 UTC
*** Bug 237969 has been marked as a duplicate of this bug. ***
Comment 5 Antoine Brodin freebsd_committer 2019-05-20 21:05:34 UTC
Created attachment 204492 [details]
Patch to update graphics/py-pyproj from 1.9.6 to 2.1.3
Comment 6 Antoine Brodin freebsd_committer 2019-05-20 21:14:05 UTC
Created attachment 204495 [details]
Update graphics/proj to 6.1.0 and graphics/py-pyproj to 2.1.3
Comment 7 Antoine Brodin freebsd_committer 2019-05-21 07:36:12 UTC
New failures on 12.0 amd64:

+ {"origin"=>"astro/libosmium", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"astro/merkaartor", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"cad/sumo", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"databases/postgis20", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"databases/postgis21", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"databases/postgis22", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"databases/spatialite_gui", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/libght", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/R-cran-rgdal", "phase"=>"stage", "errortype"=>"configure_error"}
+ {"origin"=>"graphics/libreatlas", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/openorienteering-mapper", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/p5-Geo-Proj4", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/py-cartopy", "flavor"=>"py27", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/py-cartopy", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"math/R-cran-sf", "phase"=>"stage", "errortype"=>"configure_error"}
+ {"origin"=>"math/octave-forge-octproj", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"math/saga", "phase"=>"build", "errortype"=>"missing_header"}
+ {"origin"=>"misc/survex", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"misc/zygrib", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"science/cdo", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"science/gnudatalanguage", "phase"=>"build", "errortype"=>"???"}

New failure logs on 12.0 amd64:

http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/libosmium-2.15.1_1.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/merkaartor-0.18.2_16.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/sumo-0.31.0.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/postgis20-2.0.7_6.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/postgis21-2.1.8_3.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/postgis22-2.2.6_3.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/spatialite_gui-1.7.1_6.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/libght-0.1.0.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/R-cran-rgdal-1.3.6_1.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/libreatlas-1.0.0a_21.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/openorienteering-mapper-0.8.4_1.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/p5-Geo-Proj4-1.07.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/py36-cartopy-0.17.0_1.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/py27-cartopy-0.17.0_1.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/R-cran-sf-0.7.1_1.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/octave-forge-octproj-1.1.5_13.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/saga-7.2.0.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/survex-1.2.38.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/zygrib-8.0.1_2.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/cdo-1.9.6_1.log
http://package18.nyi.freebsd.org/data/120amd64-default-PR237932/2019-05-20_21h29m07s/logs/gnudatalanguage-0.9.9_7.log
Comment 8 wen 2019-05-24 13:53:23 UTC
Currently I have patched these ports to build with proj6:
1) astro/libosmium
2)astro/merkaartor
3) graphics/libreatlas
4)science/cdo
5)databases/spatialite_gui
6)graphics/R-cran-rgdal
7) graphics/openorienteering-mapper

these ports had been marked with DEPRECARED and should be removed from portstree soon, so I think it was not needed patch:
1)databases/postgis20
2)databases/postgis21
3)databases/postgis22

these ports needs help to build with proj6:
1)cad/sumo
2)science/gnudatalanguage
3)misc/zygrib
4) graphics/p5-Geo-Proj4
5)graphics/py-cartopy
6) math/R-cran-sf
7)math/octave-forge-octproj
8)math/saga
9)misc/survex
Comment 9 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-05-25 11:02:25 UTC
(In reply to wen from comment #8)

> 5)graphics/py-cartopy

It works for me by adding "CPPFLAGS+=-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1" to Makefile.
Comment 10 Rainer Hurling 2019-05-25 11:46:08 UTC
(In reply to wen from comment #8)

The upcoming release of SAGA GIS 7.3.0 (hopefully in a few days) will have support for graphics/proj version 6.1.0. I have tested a recent trunk version and it builds, installs and runs fine already.

If SAGA GIS 7.3.0 is out, I will submit a PR short-dated.
Comment 11 wen 2019-05-27 08:08:34 UTC
Today these ports had been patched to build with proj6:
1) astro/libosmium
2)astro/merkaartor
3) graphics/libreatlas
4)science/cdo
5)databases/spatialite_gui
6)graphics/R-cran-rgdal
7) graphics/openorienteering-mapper
8)cad/sumo
9)science/gnudatalanguage
10)graphics/py-cartopy(Thanks to sunpoet@)
11)math/saga(wait 7.3.0, thanks to rhurlin@gwdg.de)

these ports had been marked with DEPRECARED and should be removed from portstree soon, so I think it was not needed patch:
1)databases/postgis20
2)databases/postgis21
3)databases/postgis22

these ports needs help to build with proj6:
1)misc/survex
2)math/octave-forge-octproj
3)misc/zygrib
4)graphics/p5-Geo-Proj4
5)math/R-cran-sf

wen
Comment 12 wen 2019-05-29 03:20:18 UTC
Now math/octave-forge-octproj and math/R-cran-sf had been patched.
There are 3 ports still break build with proj6:
1)misc/survex
2)misc/zygrib
3)graphics/p5-Geo-Proj4

Seems no simple way to fix the build in ports.
Have to contact with upstream.

wen
Comment 13 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-06-01 22:36:07 UTC
Add yuri (maintainer of misc/survex and misc/zygrib) to CC list.
Comment 14 Yuri Victorovich freebsd_committer 2019-06-01 22:42:37 UTC
Created attachment 204768 [details]
patch-to-make-proj5-install-separately.patch

These 2 fail and can't be fixed to work with proj6 at this time.

IMO graphics/proj needs to be forked into graphics/proj5. I've sent the patch to wen@, but am attaching it here too.
Comment 15 wen 2019-06-03 02:02:02 UTC
(In reply to Yuri Victorovich from comment #14)
Thank your patch.
Seems you removed the man file, install data file into same directory as proj.

wen
Comment 16 wen 2019-06-03 02:13:40 UTC
Created attachment 204793 [details]
- Repocopy graphics/proj --> graphics/proj5

- Repocopy graphics/proj --> graphics/proj5
- Fix build of misc/zygrib, misc/survex and graphics/p5-Geo-Proj4
Comment 17 wen 2019-06-03 03:10:56 UTC
Created attachment 204795 [details]
second patch to update proj to 6.1.0, fix some build

second patch to update proj to 6.1.0, fix some build
Comment 18 Yuri Victorovich freebsd_committer 2019-06-03 04:08:45 UTC
(In reply to wen from comment #15)

I removed man pages because they still install into the default location, but aren't really needed in the fork anyway because the fork is temporary.
Comment 19 Antoine Brodin freebsd_committer 2019-06-03 05:51:27 UTC
Please mark the obsolete patches as obsolete.
Comment 20 Wen Heping freebsd_committer 2019-06-03 13:26:38 UTC
Created attachment 204802 [details]
new patch to update proj to 6.1.0 and fix some broken ports

new patch to update proj to 6.1.0 and fix some broken ports
Comment 21 Wen Heping freebsd_committer 2019-06-03 13:28:20 UTC
Created attachment 204803 [details]
Patch to repocopy graphics/proj --> graphics/proj5 and fix depends of 3 ports

Patch to repocopy graphics/proj --> graphics/proj5 and fix depends of 3 ports
Comment 22 wen 2019-06-10 05:59:16 UTC
(In reply to Antoine Brodin from comment #19)
I obsoleted the previous patches.
Would you run a exp-run with the patch I uploaded at 3rd, June ?

Thanks !

wen
Comment 24 Wen Heping freebsd_committer 2019-06-16 04:19:11 UTC
Created attachment 205095 [details]
patch to update proj to 6.1.0

revised patch.
Comment 25 Wen Heping freebsd_committer 2019-06-16 04:23:18 UTC
(In reply to Antoine Brodin from comment #23)

converters/osm2pgsql, graphics/libgeotiff and databases/spatialite had been fixed before, it is my fault to forget to included the patch to previous patch. I submitted the revised patch just now.

I did not patch postgis21 since it was marked DEPRECATED and should be removed soon.

wen
Comment 27 Rainer Hurling 2019-06-16 19:06:56 UTC
(In reply to Antoine Brodin from comment #26)

For math/saga, please see comment #10. I am waiting for the next release of SAGA GIS, 7.3.0, which is advertised to be forthcoming.
Comment 28 Wen Heping freebsd_committer 2019-06-17 04:03:02 UTC
Created attachment 205159 [details]
Revised patch , fixed saga and libght

Revised patch , fixed saga and libght
Comment 29 Wen Heping freebsd_committer 2019-06-17 04:05:16 UTC
Created attachment 205160 [details]
Repocopy proj-->proj5 and fix 4 ports

Repocopy proj-->proj5 and fix 4 ports
Comment 30 Wen Heping freebsd_committer 2019-06-17 04:06:32 UTC
(In reply to Antoine Brodin from comment #26)
Both fixed in my patch submitted just now.
Comment 31 Antoine Brodin freebsd_committer 2019-06-17 11:46:45 UTC
(In reply to Wen Heping from comment #30)

math/saga still fails
Comment 32 Rainer Hurling 2019-06-25 04:46:03 UTC
(In reply to Antoine Brodin from comment #31)

I just submitted bug #238795 for the update of math/saga to version 7.3.0. SAGA GIS is able now to use graphics/proj 5.1.0 or instead the upcoming proj 6.1.x.

We all look forward to get proj 6.1.0 in the tree ;)
Comment 33 Wen Heping freebsd_committer 2019-06-25 14:52:43 UTC
Created attachment 205330 [details]
Revised patch, include saga fix

Revised patch, include saga fix, copied from rhurlin@gwdg.de
Comment 34 Wen Heping freebsd_committer 2019-06-25 14:55:03 UTC
Created attachment 205331 [details]
Repocopy proj --> proj5, fix 3 ports

Repocopy proj --> proj5, fix 3 ports
Comment 35 Antoine Brodin freebsd_committer 2019-06-25 14:56:00 UTC
Can you refresh the patch?  It's like 2k revisions behind.
Comment 36 Wen Heping freebsd_committer 2019-06-26 12:00:48 UTC
Created attachment 205353 [details]
Refresh the patch-20190626

Refresh the patch-20190626
Comment 37 Wen Heping freebsd_committer 2019-06-26 12:01:19 UTC
(In reply to Antoine Brodin from comment #35)
Done.
Comment 38 Antoine Brodin freebsd_committer 2019-06-26 18:02:57 UTC
Exp-run looks fine.

Please mark proj5 and the 3 ports depending on it as DEPRECATED with an EXPIRATION_DATE in a few months.
Comment 39 commit-hook freebsd_committer 2019-06-27 00:33:13 UTC
A commit references this bug:

Author: wen
Date: Thu Jun 27 00:32:53 UTC 2019
New revision: 505187
URL: https://svnweb.freebsd.org/changeset/ports/505187

Log:
  - Repocopy graphics/proj --> graphics/proj5
  - Mark DEPRECATED and set EXPIRATION_DATE
  - Set CONFLICTS_INSTALL with proj

  PR:		237932
  Submitted by:	wenheping2000@hotmail.com(myself)
  Approved by:	maintainer(timeout, > 30 days)
  Exp-run by:	antoine@

Changes:
  head/graphics/Makefile
  head/graphics/proj5/
  head/graphics/proj5/Makefile
Comment 40 commit-hook freebsd_committer 2019-06-27 02:54:12 UTC
A commit references this bug:

Author: wen
Date: Thu Jun 27 02:53:48 UTC 2019
New revision: 505193
URL: https://svnweb.freebsd.org/changeset/ports/505193

Log:
  - Change DEPENDS from graphics/proj to graphics/proj5
  - Mark DEPRECATED and set EXPIRATION_DATE

  PR:		237932
  Submitted by:	wenheping2000@hotmail.com(myself)
  Approved by:	portmgr@(implicit, fix build)

Changes:
  head/graphics/p5-Geo-Proj4/Makefile
  head/misc/survex/Makefile
  head/misc/zygrib/Makefile
Comment 41 commit-hook freebsd_committer 2019-06-27 03:37:48 UTC
A commit references this bug:

Author: wen
Date: Thu Jun 27 03:37:12 UTC 2019
New revision: 505194
URL: https://svnweb.freebsd.org/changeset/ports/505194

Log:
  - Update to 6.1.0 and fix some ports
  - Add missing DEPENDS
  - Add TEST_TARGET
  - Take maintainership

  PR:		237932, 238795
  Submitted by:	wenheping2000@hotmail.com,rhurlin@gwdg.de
  Approved by:	maintainer(timeout, > 30 days), portmgr@(implicit, fix build)
  Exp-run by:	antoine@
  Thanks to:	antoine@, sunpoet@, rhurlin@gwdg.de

Changes:
  head/astro/libosmium/Makefile
  head/astro/merkaartor/Makefile
  head/cad/sumo/Makefile
  head/cad/sumo/distinfo
  head/cad/sumo/pkg-plist
  head/converters/osm2pgsql/Makefile
  head/databases/spatialite/Makefile
  head/databases/spatialite_gui/Makefile
  head/databases/spatialite_gui/distinfo
  head/devel/libght/Makefile
  head/graphics/R-cran-rgdal/Makefile
  head/graphics/R-cran-rgdal/distinfo
  head/graphics/libgeotiff/Makefile
  head/graphics/libgeotiff/distinfo
  head/graphics/libgeotiff/pkg-plist
  head/graphics/libreatlas/Makefile
  head/graphics/libreatlas/distinfo
  head/graphics/openorienteering-mapper/Makefile
  head/graphics/proj/Makefile
  head/graphics/proj/distinfo
  head/graphics/proj/pkg-plist
  head/graphics/py-cartopy/Makefile
  head/graphics/py-pyproj/Makefile
  head/graphics/py-pyproj/distinfo
  head/graphics/py-pyproj/pkg-descr
  head/math/R-cran-sf/Makefile
  head/math/R-cran-sf/distinfo
  head/math/octave-forge-octproj/Makefile
  head/math/octave-forge-octproj/distinfo
  head/math/saga/Makefile
  head/math/saga/distinfo
  head/math/saga/files/patch-configure.ac
  head/math/saga/files/patch-src_tools_io_io__shapes__las_las__export.cpp
  head/math/saga/files/patch-src_tools_io_io__shapes__las_las__import.cpp
  head/math/saga/files/patch-src_tools_io_io__shapes__las_las__info.h
  head/math/saga/pkg-plist
  head/science/cdo/Makefile
  head/science/gnudatalanguage/Makefile
Comment 42 Marcin Gryszkalis 2019-07-14 12:12:37 UTC
fyi, Geo::Proj4 (p5-Geo-Proj4) is working on compatibility with new proj. No ETA. https://rt.cpan.org/Public/Bug/Display.html?id=129389