Bug 237939 - emulators/virtualbox-ose: 5.2.30: fails to build/kmk *** No rule to make target
Summary: emulators/virtualbox-ose: 5.2.30: fails to build/kmk *** No rule to make target
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-17 08:11 UTC by O. Hartmann
Modified: 2019-08-26 07:35 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments
Fix build by use external libopus (1.94 KB, patch)
2019-05-17 11:13 UTC, Dima Panov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2019-05-17 08:11:55 UTC
On recent 12-STABLE and CURRENT as well as their poudriere counterparts, the recent update of port emulators/virtualbox-ose (5.2.30) fails to build with the error shown below.


[...]
===>  Building for virtualbox-ose-5.2.30
cd /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30 && /bin/sh -c '. /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/env.sh &&  VBOX_LIBPATH_X11=/usr/local VBOX_FREEBSD_SRC=/usr/src/sys /usr/local/bin/kmk -j12'
Config.kmk:2885: /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/DynamicConfig.kmk: No such file or directory
Config.kmk:7277: /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/revision.kmk: No such file or directory
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/src/VBox/Main/Makefile.kmk:221: /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/vboxapiwrap.kmk: No such file or directory
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/src/libs/Makefile.kmk:87: /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/src/libs/libopus-1.2.1/Makefile.kmk: No such file or directory
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/kBuild/footer-pass2-installs.kmk:67: warning: overriding recipe for target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/bin/src/vboxdrv/include/iprt/crc.h'
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/kBuild/footer-pass2-installs.kmk:67: warning: ignoring old recipe for target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/bin/src/vboxdrv/include/iprt/crc.h'
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/kBuild/footer-pass2-installs.kmk:67: warning: overriding recipe for target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/dist/bin/src/vboxdrv/include/iprt/crc.h'
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/kBuild/footer-pass2-installs.kmk:67: warning: ignoring old recipe for target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/dist/bin/src/vboxdrv/include/iprt/crc.h'
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/kBuild/footer-pass2-installs.kmk:67: warning: overriding recipe for target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/bin/src/vboxdrv/include/iprt/net.h'
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/kBuild/footer-pass2-installs.kmk:67: warning: ignoring old recipe for target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/bin/src/vboxdrv/include/iprt/net.h'
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/kBuild/footer-pass2-installs.kmk:67: warning: overriding recipe for target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/dist/bin/src/vboxdrv/include/iprt/net.h'
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/kBuild/footer-pass2-installs.kmk:67: warning: ignoring old recipe for target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/out/freebsd.amd64/release/dist/bin/src/vboxdrv/include/iprt/net.h'
kmk: *** No rule to make target `/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.30/src/libs/libopus-1.2.1/Makefile.kmk'.  Stop.
*** Error code 2

Stop.
make[1]: stopped in /usr/ports/emulators/virtualbox-ose
*** Error code 1
Comment 1 VVD 2019-05-17 10:38:40 UTC
Same here on 12.0-p4 amd64 and i386.
Comment 2 Dima Panov freebsd_committer 2019-05-17 11:13:23 UTC
Created attachment 204424 [details]
Fix build by use external libopus

Fix build by use external libopus
Comment 3 Dima Panov freebsd_committer 2019-05-17 11:15:56 UTC
(In reply to VVD from comment #1)

Enable VPX for videorecording require libopus for audio support, but it dropped from bundle.

Patch add external libopus dependency and make it mandatory with VPX enabled
Comment 4 Dima Panov freebsd_committer 2019-05-17 11:41:07 UTC
-nox11 looks to be broken at all — errors on display functions

/wrkdirs/usr/ports/emulators/virtualbox-ose-nox11/work/VirtualBox-5.2.30/src/VBox/Main/src-client/ConsoleImpl.cpp:6774:29: error: no member named 'i_videoRecSendAudio' in 'Display'
        int rc2 = mDisplay->i_videoRecSendAudio(pvData, cbData, uDurationMs);
Comment 5 Jung-uk Kim freebsd_committer 2019-05-17 12:07:49 UTC
I just committed a patch to restore the previous behaviour.  Please update the port and try again.  Sorry for the breakage.
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-26 04:46:08 UTC
(In reply to Jung-uk Kim from comment #5)

If this is resolved, please assign yourself (or the committer that resolved) and Close
Comment 7 O. Hartmann 2019-08-26 06:10:35 UTC
The problem is gone for me, I can't speak for other. But as the initiator of this PR, I'll close it.
Comment 8 VVD 2019-08-26 07:35:30 UTC
Work for me too.