Bug 237969 - graphics/py-pyproj: Update to 2.1.3
Summary: graphics/py-pyproj: Update to 2.1.3
Status: Closed DUPLICATE of bug 237932
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on: 237932
Blocks:
  Show dependency treegraph
 
Reported: 2019-05-18 16:54 UTC by Rainer Hurling
Modified: 2019-05-20 21:04 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (fmysh)


Attachments
Patch to update graphics/py-pyproj from 1.9.6 to 2.1.3 (2.50 KB, patch)
2019-05-18 16:54 UTC, Rainer Hurling
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Hurling freebsd_committer 2019-05-18 16:54:48 UTC
Created attachment 204448 [details]
Patch to update graphics/py-pyproj from 1.9.6 to 2.1.3

In preparation of the upcoming update of graphics/proj[1] to version 6.1.0, an update is needed for graphics/py-pyproj. py-pyproj is needed for example as a dependency for graphics/qgis.

This version supports at minimum proj version 6.0.0 !
So it should be committed as a successor of bug #237932


What this patch should do:
- Update from version 1.9.6 to 2.1.3
- Add USE_PYTHON=cython and reorder
- Update PORTDOCS and PORTEXAMPLES
- Remove whitespace in pkg-descr

The patch is tested on Poudriere (11.2i/a, 12.0i/a, and HEADi/a) with graphics/proj version 6.1.0[1].

'portlint -AC' seems happy.


[1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237932
Comment 1 Antoine Brodin freebsd_committer 2019-05-20 21:04:52 UTC

*** This bug has been marked as a duplicate of bug 237932 ***