Bug 238053 - WITHOUT_FDT= does not trigger any files to be delete by make delete-old
Summary: WITHOUT_FDT= does not trigger any files to be delete by make delete-old
Status: Closed Works As Intended
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 12.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-22 18:11 UTC by Dries Michiels
Modified: 2019-06-10 08:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dries Michiels 2019-05-22 18:11:32 UTC
Hi!

In src.conf, it is documented as follows:

WITHOUT_FDT
	     Set to not	build Flattened	Device Tree support as part of the
	     base system.  This	includes the device tree compiler (dtc)	and
	     libfdt support library.

I have noticed that these files are actually not deleted after setting the flag in src.conf. I also didn't spot any Obsolete files related with this build option. How can I check that it even honors the build flag, i.e. it does not build those binaries?
Comment 1 Ed Maste freebsd_committer 2019-06-05 14:34:35 UTC
By inspection WITH_/WITHOUT_FDT does not control the build of the dtc compiler; libfdt is not an installed library so does not need to be optionally removed.
Comment 2 Dries Michiels 2019-06-07 11:22:36 UTC
Hi,

So we could say: “works as intended”?
What exactly does it control then?

Thx
Comment 3 Ed Maste freebsd_committer 2019-06-09 16:08:43 UTC
% git ls-files | ag Makefile | xargs ag MK_FDT
stand/Makefile
18:S.${MK_FDT}+=                fdt

stand/efi/Makefile
11:SUBDIR.${MK_FDT}+=   fdt

stand/efi/loader/Makefile
72:.if defined(HAVE_FDT) && ${MK_FDT} != "no"

stand/powerpc/Makefile
10:SUBDIR.${MK_FDT}+=   kboot

stand/powerpc/ofw/Makefile
24:.if ${MK_FDT} == "yes"

stand/uboot/Makefile
7:SUBDIR.${MK_FDT}+=fdt

targets/pseudo/userland/misc/Makefile.depend
10:.if ${MK_FDT} != "no"

So it appears that it controls FDT in a small set of loaders.
Comment 4 Dries Michiels 2019-06-10 08:36:41 UTC
Interesting, thank you for elaborating on this! Do you agree that the src.conf manual page entry for WITHOUT_FDT is not clear in this regard? Closing this bug.