Bug 238081 - emulators/i386-wine-devel fails to build when MONO option is set
Summary: emulators/i386-wine-devel fails to build when MONO option is set
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: David Naylor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-23 19:00 UTC by Grzegorz Junka
Modified: 2019-05-23 19:00 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (dbn)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz Junka 2019-05-23 19:00:16 UTC
It actually fails to build when both GECKO and MONO options are set. I didn't test if the build also fails when only MONO is set but the build was successful when only GECKO was set.

Log:

=======================<phase: run-depends    >============================
===>   i386-wine-devel-4.0.r1_1,1 depends on file: /usr/local/share/wine/gecko/wine_gecko-2.47-x86.msi - not found
===>   Installing existing package /packages/All/wine-gecko-devel-2.47.txz
[12rel0-gui-winetest-job-01] Installing wine-gecko-devel-2.47...
[12rel0-gui-winetest-job-01] Extracting wine-gecko-devel-2.47: ........ done
===>   i386-wine-devel-4.0.r1_1,1 depends on file: /usr/local/share/wine/gecko/wine_gecko-2.47-x86.msi - found
===>   Returning to build of i386-wine-devel-4.0.r1_1,1
===>   i386-wine-devel-4.0.r1_1,1 depends on file: /usr/local/share/wine/mono/wine-mono-4.7.1.msi - not found
===>   Installing existing package /packages/All/wine-mono-devel-4.8.3.txz
[12rel0-gui-winetest-job-01] Installing wine-mono-devel-4.8.3...
[12rel0-gui-winetest-job-01] Extracting wine-mono-devel-4.8.3: ...... done
===>   i386-wine-devel-4.0.r1_1,1 depends on file: /usr/local/share/wine/mono/wine-mono-4.7.1.msi - not found
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/i386-wine-devel
=>> Cleaning up wrkdir
===>  Cleaning for i386-wine-devel-4.0.r1_1,1
build of emulators/i386-wine-devel | i386-wine-devel-4.0.r1_1,1 ended at Thu May 23 18:56:20 UTC 2019
build time: 00:00:18
!!! build failure encountered !!!