Bug 238086 - graphics/libprojectm fails to build when PULSEAUDIO is deselected
Summary: graphics/libprojectm fails to build when PULSEAUDIO is deselected
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-23 22:53 UTC by Grzegorz Junka
Modified: 2019-05-24 14:54 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz Junka 2019-05-23 22:53:20 UTC
Fails to build when JACK is option is selected and PULSEAUDIO is deselected:

configure: error: Pulseaudio library libpulse is required.
===>  Script "configure" failed unexpectedly.
Please report the problem to yuri@FreeBSD.org [maintainer] and attach the
"/wrkdirs/usr/ports/graphics/libprojectm/work/projectm-3.1.0/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/libprojectm
=>> Cleaning up wrkdir
===>  Cleaning for libprojectM-3.1.0_3
build of graphics/libprojectm | libprojectM-3.1.0_3 ended at Thu May 23 22:29:19 UTC 2019
build time: 00:00:50
!!! build failure encountered !!!
Comment 1 Yuri Victorovich freebsd_committer 2019-05-23 23:17:00 UTC
It seems that you need to create this bug report for the upstream.
Comment 2 Yuri Victorovich freebsd_committer 2019-05-24 04:39:01 UTC
Grzegorz,

Thank you for creating this bug report.

projectm has moved to github (https://github.com/projectM-visualizer/projectm) and has a new version 3.1.1-rc4 available. It doesn't build on FreeBSD for some unrelated reasons, but pulseaudio requirement seems to be fixed there.

Please wait until the port is updated with the new version.

Yuri
Comment 3 Grzegorz Junka 2019-05-24 10:01:47 UTC
I just tested and it also fails when both PULSEAUDIO and JACK are selected:

===>  Building package for libprojectM-3.1.0_3
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/libprojectm/work/stage/usr/local/bin/projectM-jack:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/libprojectm/work/stage/usr/local/share/applications/projectM-jack.desktop:No such file or directory
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/libprojectm
=>> Cleaning up wrkdir
===>  Cleaning for libprojectM-3.1.0_3
build of graphics/libprojectm | libprojectM-3.1.0_3 ended at Fri May 24 09:37:17 UTC 2019
build time: 00:01:31
!!! build failure encountered !!!


So, basically it currently only builds with default options.

On a side note, shouldn't the defect be closed when it's fixed in ports rather than upstream?
Comment 4 commit-hook freebsd_committer 2019-05-24 13:55:13 UTC
A commit references this bug:

Author: yuri
Date: Fri May 24 13:54:09 UTC 2019
New revision: 502468
URL: https://svnweb.freebsd.org/changeset/ports/502468

Log:
  graphics/libprojectm: Only builds with default options PULSEAUDIO=ON JACK=OFF

  The new version 3.1.1-rc4 appears to have options reworked, but 3.1.1 itselfdoesn't build for unrelated reasons that were reported to the upstream.
  Also add USES=sdl

  PR:		238086
  Reported by:	Grzegorz Junka <list1@gjunka.com>

Changes:
  head/graphics/libprojectm/Makefile
Comment 5 Yuri Victorovich freebsd_committer 2019-05-24 13:56:34 UTC
(In reply to Grzegorz Junka from comment #3)

I marked options as broken. I am reluctant to spend time fixing them when the new option with reworked options is pending. Hopefully, they will fix issues soon and it will land in the ports. (https://github.com/projectM-visualizer/projectm/issues/211)

Thank you for reporting the issue!
Yuri
Comment 6 Yuri Victorovich freebsd_committer 2019-05-24 13:58:19 UTC
(In reply to Yuri Victorovich from comment #5)

Typo: *new version*
-----
pulseaudio is explicitly required in the current version (this is erroneous IMO), but is optional in the new pending one.
Comment 7 Grzegorz Junka 2019-05-24 14:54:42 UTC
(In reply to Yuri Victorovich from comment #5)

Great, many thanks for updating the Makefile! I also think that marking the option as broken is easiest and most user friendly for now, until the new version has been ported.