Bug 238133 - mail/libesmtp unbreak with openssl111
Summary: mail/libesmtp unbreak with openssl111
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Alexey Dokuchaev
URL:
Keywords:
: 229017 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-26 09:13 UTC by Harald Schmalzbauer
Modified: 2020-07-07 11:51 UTC (History)
4 users (show)

See Also:


Attachments
conditionally mark broken, depending on OPENSSL option (1.01 KB, patch)
2019-05-26 09:13 UTC, Harald Schmalzbauer
no flags Details | Diff
svn-diff-libesmtp-openssl111 (3.48 KB, patch)
2019-08-18 23:03 UTC, Walter Schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Schmalzbauer 2019-05-26 09:13:55 UTC
Created attachment 204615 [details]
conditionally mark broken, depending on OPENSSL option

In r497650 https://svnweb.freebsd.org/ports?view=revision&revision=497650
this port was marked broken on stable/12 and head, unconditionally if OPENSSL option is true or not.
I suggest disabling OPENSSL default option for now and allow users to build that port (and most likely the package depending on libesmtp, like GeomWatch, which in many cases will use a LAN MSA, where TLS isn't a prerequisite – but GeomWatch can do it's job).

At least the options check for OPENSSL must be included, since if the user deselects OPENSSL, the port isn't broken.

See also:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=229017
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-08-18 23:03:22 UTC
Created attachment 206682 [details]
svn-diff-libesmtp-openssl111

I got it from here:
https://github.com/openwrt/packages/blob/master/libs/libesmtp/patches/100-openssl-1.1.patch

Build tested with libressl and openssl111. Not tested with openssl-base.
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-08-18 23:05:02 UTC
*** Bug 229017 has been marked as a duplicate of this bug. ***
Comment 3 commit-hook freebsd_committer 2020-07-07 11:47:30 UTC
A commit references this bug:

Author: danfe
Date: Tue Jul  7 11:47:19 UTC 2020
New revision: 541412
URL: https://svnweb.freebsd.org/changeset/ports/541412

Log:
  Pull the patch from Gentoo Linux to unbreak the build against contemporary
  versions of OpenSSL.

  PR:	238133

Changes:
  head/mail/libesmtp/Makefile
  head/mail/libesmtp/distinfo
Comment 4 Alexey Dokuchaev freebsd_committer 2020-07-07 11:51:20 UTC
I've pulled the patch from Gentoo Linux instead, as it looked more complete than OpenWRT's one, see the hunk about TLSv1_client_method() vs. TLS_client_method().

Committed as ports r541412.