Bug 238176 - irc/ircII: update to 20190117
Summary: irc/ircII: update to 20190117
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Christoph Moench-Tegeder
URL: http://ircii.warped.com/ircii-current...
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2019-05-27 19:23 UTC by Christoph Moench-Tegeder
Modified: 2019-06-06 21:57 UTC (History)
1 user (show)

See Also:
koobs: maintainer-feedback+


Attachments
update ircII to 200190117 (3.17 KB, patch)
2019-05-27 19:23 UTC, Christoph Moench-Tegeder
koobs: maintainer-approval-
Details | Diff
update to 20190117 and fix bugs (4.36 KB, patch)
2019-05-29 11:02 UTC, andrew
andrew: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Moench-Tegeder freebsd_committer 2019-05-27 19:23:09 UTC
Created attachment 204656 [details]
update ircII to 200190117

update is nearly trivial (patch is gone as they restructured the code).
Comment 1 andrew 2019-05-28 04:55:14 UTC
Comment on attachment 204656 [details]
update ircII to 200190117

20190117 drops core all over the place (try with /help commands for example), so I do not approve the update.
Comment 2 andrew 2019-05-29 11:02:02 UTC
Created attachment 204691 [details]
update to 20190117 and fix bugs

This version fixes the bugs I've been able to identify so far.
Comment 3 commit-hook freebsd_committer 2019-06-06 21:43:26 UTC
A commit references this bug:

Author: cmt
Date: Thu Jun  6 21:42:25 UTC 2019
New revision: 503606
URL: https://svnweb.freebsd.org/changeset/ports/503606

Log:
  update irc/ircII to 20190117

  PR:		238176
  Approved by:	maintainer (andrew at tao11 dot riddles dot org dot uk)

Changes:
  head/irc/ircII/Makefile
  head/irc/ircII/distinfo
  head/irc/ircII/files/patch-source_alias.c
  head/irc/ircII/files/patch-source_help.c
  head/irc/ircII/files/patch-source_mksiginc.c
  head/irc/ircII/pkg-plist
Comment 4 Christoph Moench-Tegeder freebsd_committer 2019-06-06 21:45:53 UTC
sorry for missing the problems in the first place, thanks for the patch, sorry for being late... committed as ports r503606
further testing shows that ssl support seems to be broken, and it was broken in the previous version, so this is not a new regression. I'll try to find a patch for that...
Comment 5 Christoph Moench-Tegeder freebsd_committer 2019-06-06 21:57:58 UTC
please ignore that comment about SSL being broken - it's only the error message when you screw up, which is not very helpful (oh, and I did screw up very consistently). everything is fine.