Bug 238264 - ports-mgmt/pkg: pkg-1.11.0 doesn't work with an IPv6 only repository
Summary: ports-mgmt/pkg: pkg-1.11.0 doesn't work with an IPv6 only repository
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-pkg (Nobody)
URL:
Keywords:
: 238263 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-31 14:34 UTC by Hajimu UMEMOTO
Modified: 2019-05-31 17:33 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (pkg)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hajimu UMEMOTO freebsd_committer 2019-05-31 14:34:37 UTC
pkg-1.11.0 doesn't work with an IPv6 only repository.

% sudo pkg upgrade
Updating example repository catalogue...
pkg: http://pkg.example.org/FreeBSD:11:amd64/local/meta.txz: No address record
repository example has no meta file, using default settings
pkg: http://pkg.example.org/FreeBSD:11:amd64/local/packagesite.txz: No address record
Unable to update repository example
Error updating repositories!

The cause of this problem is that libfetch shipped with pkg is compiled without INET6 definition.  I confirmed that compiling libfetch with INET6 defined fix this problem.
Comment 1 Baptiste Daroussin freebsd_committer 2019-05-31 15:00:23 UTC
fixed in 1.11.1 thanks
Comment 2 commit-hook freebsd_committer 2019-05-31 15:00:50 UTC
A commit references this bug:

Author: bapt
Date: Fri May 31 14:59:44 UTC 2019
New revision: 503177
URL: https://svnweb.freebsd.org/changeset/ports/503177

Log:
  Update to 1.11.1
  - Fix abi string for dragonfly
  - Fix libfetch built without ipv6 support [1]

  PR:		238264
  Reported by:	ume

Changes:
  head/ports-mgmt/pkg/Makefile
  head/ports-mgmt/pkg/distinfo
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-05-31 17:33:23 UTC
*** Bug 238263 has been marked as a duplicate of this bug. ***