Bug 238266 - shells/ksh93: ports r502845 PORTVERSION (2020.0.0) goes backward
Summary: shells/ksh93: Ports r502845 PORTVERSION (2020.0.0) goes backward
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Cy Schubert
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-05-31 15:25 UTC by Peter
Modified: 2019-06-11 11:44 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (saper)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2019-05-31 15:25:36 UTC
rifle:# pkg upgrade -f ksh93
Updating otis repository catalogue...
otis repository is up to date.
All repositories are up to date.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be DOWNGRADED:
        ksh93: 20141224 -> 2020.0.0.a1 [otis]

Number of packages to be downgraded: 1

697 KiB to be downloaded.

Proceed with this action? [y/N]:
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-06-01 07:27:17 UTC
Thank you for the report Peter

Assign committer of ports r502845

PORTEPOCH needs to be incremented as the version goes backward after this revision:

# pkg version -t 2020.0.0.a1 20141224
# <
Comment 2 Chris Rees freebsd_committer 2019-06-01 07:43:25 UTC
Yeah, no way around this one :(
Comment 3 Cy Schubert freebsd_committer 2019-06-01 14:51:26 UTC
Our choices are PORTEPOCH and 20200000.a1. I'm reluctant to bump PORTEPOCH if there's another way.

Thoughts?
Comment 4 Cy Schubert freebsd_committer 2019-06-01 15:35:51 UTC
PORTEPOCH bump later today.
Comment 5 Chris Rees freebsd_committer 2019-06-01 17:55:19 UTC
Yeah, I don't think forever mangling the version is a better solution.

I hate them too, but I think this is the answer:)
Comment 6 Cy Schubert freebsd_committer 2019-06-01 18:28:30 UTC
Sadly yes.
Comment 7 commit-hook freebsd_committer 2019-06-01 18:37:04 UTC
A commit references this bug:

Author: cy
Date: Sat Jun  1 18:36:03 UTC 2019
New revision: 503249
URL: https://svnweb.freebsd.org/changeset/ports/503249

Log:
  Fix version going backward due to update to 2020.0.0.a1 (pointy hat to
  yours truly).

  The maintainer no longer wants to maintain ksh93 as his desire is to
  maintain a backlevel port of ksh93 in order to build and support a
  shared library for use by legacy applications, which is inconsistent
  with the direction of the att/ast team on github. I will maintain the
  port.

  PR:		237332
  PR:		238266
  Approved by:	maintiner (saper@saper.info)

Changes:
  head/shells/ksh93/Makefile
Comment 8 Marcin Cieślak 2019-06-11 10:40:13 UTC
(In reply to commit-hook from comment #7)

Cy,
Can you take over the shells/ksh93 port? Thanks
Comment 9 Marcin Cieślak 2019-06-11 10:41:46 UTC
(In reply to Marcin Cieślak from comment #8)

(sorry got confused by this " Approved by:	maintiner" line - thank you)
Comment 10 Cy Schubert freebsd_committer 2019-06-11 11:44:29 UTC
Fixed and took the port a while ago. shells/ast-ksh is under your name.