Bug 238350 - x11-wm/fvwm: Missing dependency - xload
Summary: x11-wm/fvwm: Missing dependency - xload
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Cy Schubert
URL:
Keywords: needs-qa, patch-ready
Depends on:
Blocks:
 
Reported: 2019-06-05 21:51 UTC by Ronald F. Guilmette
Modified: 2019-06-28 22:38 UTC (History)
3 users (show)

See Also:
fernape: maintainer-feedback? (cy)
fernape: merge-quarterly?


Attachments
Patch to the ports tree (657 bytes, patch)
2019-06-12 18:18 UTC, Fernando Apesteguía
no flags Details | Diff
Remove dependency on bloat. (4.19 KB, patch)
2019-06-12 19:15 UTC, Cy Schubert
no flags Details | Diff
Comment out lines to be used as samples, avoiding confusing users. (7.46 KB, patch)
2019-06-12 19:29 UTC, Cy Schubert
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald F. Guilmette 2019-06-05 21:51:28 UTC
The default theme provided with the fvwm/fvwm2 port/package assumes the presence of the xload utility, however this is utility exists in a separate port/package all to itself and that port/package is apparently not listed as a dependency of fvwm/fvwm2.
Comment 1 Fernando Apesteguía freebsd_committer 2019-06-12 18:18:38 UTC
Created attachment 205011 [details]
Patch to the ports tree

Adding RUN_DEPENDS for all the default commands as present in system.fvwm2rc
Comment 2 Fernando Apesteguía freebsd_committer 2019-06-12 18:20:12 UTC
Builds fine in {11.2,12.0}{amd64,i386}
Comment 3 Cy Schubert freebsd_committer 2019-06-12 19:05:30 UTC
I'm not enamoured with dragging in and depending on packages, such as rxvt, which should be removed from the standard menu, IMO a sample people can use to create their own. In that case any not absolutely needed will be removed.
Comment 4 Cy Schubert freebsd_committer 2019-06-12 19:15:09 UTC
Created attachment 205014 [details]
Remove dependency on bloat.

Rather than depend on bloat that most people do not want, remove the dependencies from the sample file. The sample file was there for people to use as a starting point for the end-user to build their own. Not as a provided out-of-the-box config, except to get oneself started.

This patch removes the bloat.
Comment 5 Cy Schubert freebsd_committer 2019-06-12 19:29:48 UTC
Created attachment 205015 [details]
Comment out lines to be used as samples, avoiding confusing users.

This patch comments out anything that might confuse users into thinking these packages must be installed. I see no reason to add dependencies that would bloat an installed system with packages most people don't need. Much of the software listed, such as mosaic, no longer exist and should be replaced with contemporary software, such as firefox or chromium. I doubt people would accept having my favourite browser installed because I choose to use it as a sample. Therefore this patch comments out the lines which are clearly samples (@sample) so as not to confuse people.
Comment 6 commit-hook freebsd_committer 2019-06-28 20:01:04 UTC
A commit references this bug:

Author: cy
Date: Fri Jun 28 20:00:02 UTC 2019
New revision: 505298
URL: https://svnweb.freebsd.org/changeset/ports/505298

Log:
  Comment out false dependencies in the sample system.fvwm2rc. Ulike
  Gnome, KDE, XFCE, and LXDE, which are windowing enviornments, FVWM
  is a simple window manager which simply controls the the placement
  of windows and provides decoration for windows. Wereas a windowing
  environment (like Gnome or KDE) is an ecosystem of themes, settings
  (like keyboard, mouse, network, and others), and a suite of
  applications within that ecosystem. FVWM is not this. There remove
  references sample applications, many which do not exist any more.
  Some people erroneously expect the samples to be installed when
  FVWM is installed.

  The samples still exist in the system.fvwm2rc file as comments.
  Users can install applications of their choosing and uncomment
  the desired samples, though it is recommended that people create
  their own ~/.fvwm2rc file instead.

  PR:		238350

Changes:
  head/x11-wm/fvwm2/Makefile
  head/x11-wm/fvwm2/files/system.fvwm2rc
Comment 7 Cy Schubert freebsd_committer 2019-06-28 20:05:03 UTC
Not a bug.
Comment 8 Ronald F. Guilmette 2019-06-28 22:38:49 UTC
(In reply to Cy Schubert from comment #7)

For whatever little it's worth, let me just say that I am OK with this PR being closed as it has been.  I understand the reasons for it.