Bug 238359 - www/py-django-auth-ldap: Update to 2.0.0 and taking maintainership
Summary: www/py-django-auth-ldap: Update to 2.0.0 and taking maintainership
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kai Knoblich
URL: https://github.com/django-auth-ldap/d...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-06 08:17 UTC by Kai Knoblich
Modified: 2019-06-20 12:51 UTC (History)
1 user (show)

See Also:
kai: maintainer-feedback-


Attachments
py-django-auth-ldap-2.0.0.patch (1.35 KB, patch)
2019-06-06 08:17 UTC, Kai Knoblich
kai: maintainer-approval-
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Knoblich freebsd_committer 2019-06-06 08:17:06 UTC
Created attachment 204851 [details]
py-django-auth-ldap-2.0.0.patch

Hi,

attached is the patch that updates www/py-django-auth-ldap to 2.0.0 . I also would like to become maintainer of the port, if approved.

Changes the port:
- Taking maintainership (if approved)
- Limit to Python 3.5 or later

Changes by upstream:
- Removed support for Python 2 and 3.4.
- Removed support for end of life Django 2.0.
- Added support for Django 2.2.
- Add testing and support for Python 3.7 with Django 1.11 and 2.1.
- When :setting:`AUTH_LDAP_SERVER_URI` is set to a callable, it is now passed a
  positional ``request`` argument. Support for no arguments will continue for
  backwards compatibility but will be removed in a future version.
- Added new :setting:`AUTH_LDAP_NO_NEW_USERS` to prevent the creation of new
  users during authentication. Any users not already in the Django user
database will not be able to login.

QA:
~~~
- poudriere (11.2-, 12.0-RELEASE, 13.0-CURRENT@r348350 amd64 + i386) for the py36 flavor -> OK
- portlint -> OK
Comment 1 commit-hook freebsd_committer 2019-06-20 12:47:33 UTC
A commit references this bug:

Author: kai
Date: Thu Jun 20 12:46:40 UTC 2019
New revision: 504628
URL: https://svnweb.freebsd.org/changeset/ports/504628

Log:
  www/py-django-auth-ldap: Update to 2.0.0

  * Take maintainership due three consecutive maintainer timeouts
  * Limit to Python 3.5 and later as upstream has dropped the support for
    Python 2 and 3.4

  Changelog:

  https://github.com/django-auth-ldap/django-auth-ldap/blob/2.0.0/CHANGES

  PR:		238359
  Approved by:	maintainer timeout

Changes:
  head/www/py-django-auth-ldap/Makefile
  head/www/py-django-auth-ldap/distinfo