Bug 238364 - emulators/qemu: USES=gl is not always needed
Summary: emulators/qemu: USES=gl is not always needed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-06 13:55 UTC by Luca Pizzamiglio
Modified: 2019-08-07 10:01 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments
The solving patch (944 bytes, patch)
2019-06-06 13:55 UTC, Luca Pizzamiglio
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Pizzamiglio freebsd_committer 2019-06-06 13:55:15 UTC
Created attachment 204858 [details]
The solving patch

Currently, USES=gl is always enabled.

This patch will enable USES=gl only when GTK3 and/or OPENGL options are selected.
Comment 1 commit-hook freebsd_committer 2019-08-05 10:48:46 UTC
A commit references this bug:

Author: bofh
Date: Mon Aug  5 10:48:24 UTC 2019
New revision: 508158
URL: https://svnweb.freebsd.org/changeset/ports/508158

Log:
  emulators/qemu2: Mark DEPRECATED

  - qemu 3.X branch in the tree seems like stable as no major complainnt has
    beeen reached and there has been no commit to 2.X ranch since last 13
    months. 3.1.X will be updated shortly after build completes
  - USES=gl is not always needed [1]

  PR:		238364 [1]
  Submitted by:	pizzamig [1]

Changes:
  head/emulators/qemu2/Makefile
Comment 2 Luca Pizzamiglio freebsd_committer 2019-08-05 14:45:58 UTC
Thanks for committing it!
Comment 3 Muhammad Moinur Rahman freebsd_committer 2019-08-05 14:48:02 UTC
Just committed for qemu2. Still qemo30, qemu, qemu40 and qemu-devel are WIP. So going to keep it open. :P
Comment 4 commit-hook freebsd_committer 2019-08-06 09:31:03 UTC
A commit references this bug:

Author: bofh
Date: Tue Aug  6 09:31:01 UTC 2019
New revision: 508241
URL: https://svnweb.freebsd.org/changeset/ports/508241

Log:
  emulators/qemu30: QEMU CPU Emulator

  - Specific to version 3.0 in preperation for upgrading qemu to 3.1.X
  - USES=gl is not always needed [1]

  PR:             238364 [1]
  Submitted by:   pizzamig [1]

Changes:
  head/emulators/Makefile
  head/emulators/qemu30/
  head/emulators/qemu30/Makefile
Comment 5 commit-hook freebsd_committer 2019-08-06 09:47:05 UTC
A commit references this bug:

Author: bofh
Date: Tue Aug  6 09:46:44 UTC 2019
New revision: 508242
URL: https://svnweb.freebsd.org/changeset/ports/508242

Log:
  emulators/qemu: Update version 3.0.1=>3.1.1

  - USES=gl is not always needed [1]

  PR:		238364 [1]
  Submitted by:	pizzamig [1]

Changes:
  head/emulators/qemu/Makefile
  head/emulators/qemu/distinfo
  head/emulators/qemu/files/patch-configure
  head/emulators/qemu/files/patch-hw_rdma_Makefile.objs
  head/emulators/qemu/files/patch-hw_rdma_vmw_pvrdma__cmd.c
  head/emulators/qemu/pkg-plist
Comment 6 commit-hook freebsd_committer 2019-08-07 09:59:09 UTC
A commit references this bug:

Author: bofh
Date: Wed Aug  7 09:58:18 UTC 2019
New revision: 508308
URL: https://svnweb.freebsd.org/changeset/ports/508308

Log:
  emulators/qemu-devel: Update version 3.1.0=>4.0.0

  - USES=gl is not always needed [1]

  PR:		238364 [1]
  Submitted by:	pizzamig [1]
  Reported by:	bz

Changes:
  head/emulators/qemu-devel/Makefile
  head/emulators/qemu-devel/distinfo
  head/emulators/qemu-devel/files/patch-Makefile
  head/emulators/qemu-devel/files/patch-configure
  head/emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
  head/emulators/qemu-devel/files/patch-include_net_net.h
  head/emulators/qemu-devel/files/patch-include_qemu_atomic.h
  head/emulators/qemu-devel/files/patch-net_tap-bsd.c
  head/emulators/qemu-devel/files/patch-qemu-doc.texi
  head/emulators/qemu-devel/pkg-plist