Bug 238373 - mail/geary: update to 3.36.1
Summary: mail/geary: update to 3.36.1
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on: 243743 249877
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-06 18:42 UTC by Greg V
Modified: 2020-10-17 16:49 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
geary.patch (3.15 KB, patch)
2019-06-06 18:42 UTC, Greg V
no flags Details | Diff
geary.patch (3.35.2) (3.54 KB, patch)
2020-01-30 21:54 UTC, Greg V
no flags Details | Diff
geary.patch (3.36.1) (5.01 KB, patch)
2020-04-06 00:50 UTC, Greg V
no flags Details | Diff
geary.patch (3.36.1) v2 (4.84 KB, patch)
2020-04-13 14:20 UTC, Greg V
no flags Details | Diff
geary.patch (3.36.1) v3 (5.04 KB, patch)
2020-04-15 21:48 UTC, Greg V
no flags Details | Diff
geary.patch (3.36.1) v4 (5.15 KB, patch)
2020-04-15 23:52 UTC, Greg V
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2019-06-06 18:42:25 UTC
Created attachment 204865 [details]
geary.patch
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-08-13 15:37:16 UTC
Maintainer feedback!
Comment 2 Greg V 2020-01-30 21:54:45 UTC
Created attachment 211206 [details]
geary.patch (3.35.2)

now at 3.35.2 - requires libpeas 1.24
Comment 3 Ting-Wei Lan 2020-02-02 07:53:13 UTC
Comment on attachment 211206 [details]
geary.patch (3.35.2)

>--- a/mail/geary/Makefile
>+++ b/mail/geary/Makefile
>@@ -2,8 +2,7 @@
> # $FreeBSD$
> 
> PORTNAME=	geary
>-PORTVERSION=	0.13.3
>-PORTREVISION=	1
>+PORTVERSION=	3.35.2
> CATEGORIES=	mail gnome
> MASTER_SITES=	GNOME
> DIST_SUBDIR=	gnome

Is there any reason that you prefer unstable releases (3.35.x) to stable releases (3.34.x)?
Comment 4 Greg V 2020-04-06 00:50:04 UTC
Created attachment 213110 [details]
geary.patch (3.36.1)

Now 3.36.1

> Is there any reason that you prefer unstable releases (3.35.x) to stable releases (3.34.x)?

Not really, I forgot about the numbering scheme when making the previous patch :D
Comment 5 Greg V 2020-04-13 14:20:12 UTC
Created attachment 213372 [details]
geary.patch (3.36.1) v2

Oh, also, canberra dependency was dropped.
Comment 6 Greg V 2020-04-15 21:48:15 UTC
Created attachment 213434 [details]
geary.patch (3.36.1) v3

fixed gmime dependency, it's 3.0 now
Comment 7 Greg V 2020-04-15 23:52:44 UTC
Created attachment 213436 [details]
geary.patch (3.36.1) v4

final version, sorry for the spam

requires appstream-glib update: https://github.com/freebsd/freebsd-ports-gnome/commit/469110c36d16864f8be8ca9754556532e3deaf4c