Bug 238421 - devel/p5-Locale-libintl: Add NLS option to disable gettext dependency
Summary: devel/p5-Locale-libintl: Add NLS option to disable gettext dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-08 16:48 UTC by Adam Weinberger
Modified: 2019-06-23 19:24 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
Patches work better when they actually exist (1.20 KB, patch)
2019-06-10 21:18 UTC, Adam Weinberger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Weinberger freebsd_committer 2019-06-08 16:48:26 UTC
Hi Po-Chuan,

I'm curious about your thoughts on this patch. It adds an NLS option to p5-Locale-libintl, to disable the gettext dependency.

The problem is that texinfo, used by a huge proportion of the ports tree, has an NLS option to disable gettext, but it's brought in as a runtime dependency anyway because of p5-Locale-libintl.

With this patch, texinfo builds happily without gettext being around. p5-Locale-libintl also passes all the included tests.
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-06-10 15:40:10 UTC
I think it's OK but I didn't see the patch. :)
Comment 2 Adam Weinberger freebsd_committer 2019-06-10 17:14:51 UTC
And of course I deleted the patch as soon as I submitted the bug report. I’ll regenerate it once I get home.
Comment 3 Adam Weinberger freebsd_committer 2019-06-10 21:18:00 UTC
Created attachment 204962 [details]
Patches work better when they actually exist

Okay, let’s see if it’s any easier to evaluate a patch when it’s actually attached
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-06-16 18:56:28 UTC
It works fine in a clean environment (gettext-runtime is absent). I've added an extra patch for Makefile.PL to ensure it does not use gettext-runtime when it's already installed.

https://people.FreeBSD.org/~sunpoet/patch/devel-p5-Locale-libintl.txt
Comment 5 Adam Weinberger freebsd_committer 2019-06-16 20:23:49 UTC
Good call! I hadn't considered building outside poudriere.
Comment 6 commit-hook freebsd_committer 2019-06-23 19:22:25 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Jun 23 19:21:20 UTC 2019
New revision: 504980
URL: https://svnweb.freebsd.org/changeset/ports/504980

Log:
  Add NLS option

  PR:		238421
  Submitted by:	adamw

Changes:
  head/devel/p5-Locale-libintl/Makefile
  head/devel/p5-Locale-libintl/files/
  head/devel/p5-Locale-libintl/files/extra-patch-Makefile.PL
  head/devel/p5-Locale-libintl/pkg-plist
Comment 7 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-06-23 19:24:46 UTC
Committed. Thanks!