Bug 238447 - sysutils/fusefs-ntfs: 2017.3.23 external FUSE 29: fails mount: fuse: failed to open fuse device: No such file or directory
Summary: sysutils/fusefs-ntfs: 2017.3.23 external FUSE 29: fails mount: fuse: failed t...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-10 04:56 UTC by Jason Mours
Modified: 2019-09-15 09:39 UTC (History)
4 users (show)

See Also:
koobs: maintainer-feedback? (freebsd)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mours 2019-06-10 04:56:14 UTC
Anyone else? I have work on a windows NTFS partition.

FREEBSD 12.0-RELEASE r341666

root@machine:~ # ntfs-3g -o ro /dev/ada2p1 /mnt/ada2
fuse: failed to open fuse device: No such file or directory

root@machine:~ # ntfs-3g -o ro /dev/ntfs/<volume> /mnt/ada2
fuse: failed to open fuse device: No such file or directory

root@machine:~ # mount -o ro -t ntfs /dev/ada2p1 /mnt/ada2
mount: /dev/ada2p1: Operation not supported by device

BSD touches the drive. Fails after *pause*.

FUSE-1.5.7 from binary pkg installed.

All installed packages are from pkg binary. No source ports yet. Install is vanilla.


Seems simple, is it me?  I'm new to BSD, per se, is this something that Beastie fixes on it's own? I feel him working in the solfeg. I leave the box alone, mostly. 

The problem feels like command? Dunno, I never systemd...user>=. 

Not to pollute further, but I plan on reinstalling. Maybe re-striping..get it TRUE RED. This over the course of the week. If hu-man start to hack at bits. I would expect to be here again after.
Comment 1 Jason Mours 2019-06-10 08:01:23 UTC
Looks like mount. This goes to system. What's up with /dev? PRINT_11224488088____8888884864255555555555555544µ. Is this supposed to be funny? Goes to ~. Did I hit __DEL too often¿ It's only buffer not EFI¿ I see the same NULL to buffer when login as /usr. I could go on.µ This is a nice stream._LINE_ROTATE

Mounting linux: e2fsprogs-1.45.2
root@dae:~ #mount -t ext4 -o ro /dev/ada0p4 /mnt/linux
mount /dev/ada0p4: Operation not supported by device
Comment 2 Conrad Meyer freebsd_committer 2019-06-10 13:30:32 UTC
Does /mnt/ada2 exist?  If it does, try running ntfs-3g under truss (i.e., "truss -o mount.log ntfs-3g ..."), or failing that, maybe the ntfs-3g '-o debug'.
Comment 3 Andrey V. Elsukov freebsd_committer 2019-06-10 15:03:04 UTC
(In reply to Jason Mours from comment #0)
> Anyone else? I have work on a windows NTFS partition.
> 
> FREEBSD 12.0-RELEASE r341666
> 
> root@machine:~ # ntfs-3g -o ro /dev/ada2p1 /mnt/ada2
> fuse: failed to open fuse device: No such file or directory

You need to load fuse kernel module first.
Comment 4 Alan Somers freebsd_committer 2019-09-15 04:39:53 UTC
Definitely looks like the OP forgot to load the fuse driver.  Reopen the bug if that's not the case.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2019-09-15 09:39:26 UTC
(In reply to Alan Somers from comment #4)

Would adding instructions to the ports pkg-install message help?