Bug 238464 - net-mgmt/pmacct missing sql directory in PLIST
Summary: net-mgmt/pmacct missing sql directory in PLIST
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-10 18:21 UTC by Michael Proto
Modified: 2019-06-16 18:42 UTC (History)
0 users

See Also:
pi: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Proto 2019-06-10 18:21:44 UTC
With a default OPTIONS file, net-mgmt/pmacct refuses to install for me, due to a missing /usr/local/share/pmacct/sql directory during installation (note I'm using portmaster and a custom WRKDIRPREFIX=/tmp/__ports but this happens with a default make-all-install too):

===>   Registering installation for pmacct-1.7.3
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.64bit:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.GeoIP:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.IPv6:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.cos:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.custom_primitives:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.etype:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.export_proto:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.iface:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.label:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.mask:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.mpls:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.nat:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.sampling:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.tag2:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.timestamp:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/README.tunnel:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_bgp_v1.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v1.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v2.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v3.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v4.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v5.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v6.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v7.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v8.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-db_v9.mysql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_bgp_v1.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_bgp_v1.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v1.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v1.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v2.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v2.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v3.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v3.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v4.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v4.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v5.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v5.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v6.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v6.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v7.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v7.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v8.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v9.pgsql:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-create-table_v9.sqlite3:No such file or directory
pkg-static: Unable to access file /tmp/__ports/vault/DB/ports/net-mgmt/pmacct/work/stage/usr/local/share/pmacct/sql/pmacct-grant-db.mysql:No such file or directory
*** Error code 74

Stop.
make[1]: stopped in /vault/DB/ports/net-mgmt/pmacct
*** Error code 1

Stop.
make: stopped in /vault/DB/ports/net-mgmt/pmacct
udo make config                                                               <

  ┌──────────────────────────── pmacct-1.7.3 ──────────────────────────────┐
  │ ┌────────────────────────────────────────────────────────────────────┐ │
  │ │ [ ] AVRO      Enable avro support                                  │ │
  │ │ [ ] DEBUG     Build with debugging support                         │ │
  │ │ [x] DOCS      Build and/or install documentation                   │ │
  │ │ [x] EXAMPLES  Build and/or install examples                        │ │
  │ │ [ ] GEOIP2    Enable GeoIPv2 (libmaxminddb) support                │ │
  │ │ [x] IPV6      IPv6 protocol support                                │ │
  │ │ [ ] JANSSON   Enable Jansson support                               │ │
  │ │ [ ] KAFKA     Enable Kafka support                                 │ │
  │ │ [x] LAYER2    Enable Layer-2 support: MAC addresses and VLANs      │ │
  │ │ [ ] MYSQL     MySQL database support                               │ │
  │ │ [ ] PGSQL     PostgreSQL database support                          │ │
  │ │ [ ] PLABEL    Enable IP prefix labels                              │ │
  │ │ [ ] RABBITMQ  Enable RabbitMQ/AMQP support                         │ │
  │ │ [ ] SQLITE3   Enable SQLite3 support                               │ │
  │ │ [x] THREADS   Threading support                                    │ │
  │ └────────────────────────────────────────────────────────────────────┘ │
  ├────────────────────────────────────────────────────────────────────────┤
  │                     <  OK  >           <Cancel>                        │
  └────────────────────────────────────────────────────────────────────────┘








To get it to build I had to update PLIST to remove the /sql directory and files:

--- pkg-plist.old	2019-06-08 11:03:12.000000000 -0400
+++ pkg-plist	2019-06-10 14:12:13.744291000 -0400
@@ -76,25 +76,6 @@
 %%DATADIR%%/CONFIG-KEYS
 %%DATADIR%%/FAQS
 %%DATADIR%%/QUICKSTART
-%%DATADIR%%/sql/README.64bit
-%%DATADIR%%/sql/README.GeoIP
-%%DATADIR%%/sql/README.IPv6
-%%DATADIR%%/sql/README.cos
-%%DATADIR%%/sql/README.custom_primitives
-%%DATADIR%%/sql/README.etype
-%%DATADIR%%/sql/README.export_proto
-%%DATADIR%%/sql/README.iface
-%%DATADIR%%/sql/README.label
-%%DATADIR%%/sql/README.mask
-%%DATADIR%%/sql/README.mpls
-%%DATADIR%%/sql/README.mysql
-%%DATADIR%%/sql/README.nat
-%%DATADIR%%/sql/README.pgsql
-%%DATADIR%%/sql/README.sampling
-%%DATADIR%%/sql/README.sqlite3
-%%DATADIR%%/sql/README.tag2
-%%DATADIR%%/sql/README.timestamp
-%%DATADIR%%/sql/README.tunnel
 %%DATADIR%%/UPGRADE
 %%DATADIR%%/docs/IPFIX
 %%DATADIR%%/docs/LOOKING_GLASS_FORMAT
@@ -125,36 +106,5 @@
 %%DATADIR%%/examples/probe_sflow.conf.example
 %%DATADIR%%/examples/sampling.map.example
 %%DATADIR%%/examples/tee_receivers.lst.example
-%%DATADIR%%/sql/pmacct-create-db.pgsql
-%%DATADIR%%/sql/pmacct-create-db_bgp_v1.mysql
-%%DATADIR%%/sql/pmacct-create-db_v1.mysql
-%%DATADIR%%/sql/pmacct-create-db_v2.mysql
-%%DATADIR%%/sql/pmacct-create-db_v3.mysql
-%%DATADIR%%/sql/pmacct-create-db_v4.mysql
-%%DATADIR%%/sql/pmacct-create-db_v5.mysql
-%%DATADIR%%/sql/pmacct-create-db_v6.mysql
-%%DATADIR%%/sql/pmacct-create-db_v7.mysql
-%%DATADIR%%/sql/pmacct-create-db_v8.mysql
-%%DATADIR%%/sql/pmacct-create-db_v9.mysql
-%%DATADIR%%/sql/pmacct-create-table_bgp_v1.pgsql
-%%DATADIR%%/sql/pmacct-create-table_bgp_v1.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v1.pgsql
-%%DATADIR%%/sql/pmacct-create-table_v1.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v2.pgsql
-%%DATADIR%%/sql/pmacct-create-table_v2.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v3.pgsql
-%%DATADIR%%/sql/pmacct-create-table_v3.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v4.pgsql
-%%DATADIR%%/sql/pmacct-create-table_v4.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v5.pgsql
-%%DATADIR%%/sql/pmacct-create-table_v5.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v6.pgsql
-%%DATADIR%%/sql/pmacct-create-table_v6.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v7.pgsql
-%%DATADIR%%/sql/pmacct-create-table_v7.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v8.sqlite3
-%%DATADIR%%/sql/pmacct-create-table_v9.pgsql
-%%DATADIR%%/sql/pmacct-create-table_v9.sqlite3
-%%DATADIR%%/sql/pmacct-grant-db.mysql
 @dir lib/pmacct/examples/custom
 %%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/lg/.libs
Comment 1 Kurt Jaeger freebsd_committer 2019-06-12 19:47:49 UTC
Thanks for the report. It is caused by the pmacct Makefile copying
the files in those cases where some sql option is selected.
I need to investigate how to fix it.
Comment 2 Kurt Jaeger freebsd_committer 2019-06-16 18:42:14 UTC
Fixed.
Comment 3 commit-hook freebsd_committer 2019-06-16 18:42:28 UTC
A commit references this bug:

Author: pi
Date: Sun Jun 16 18:42:06 UTC 2019
New revision: 504360
URL: https://svnweb.freebsd.org/changeset/ports/504360

Log:
  net-mgmt/pmacct: fix pkg-plist for the default case

  PR:		238464
  Reported by:	Michael Proto <mike@jellydonut.org>

Changes:
  head/net-mgmt/pmacct/Makefile
  head/net-mgmt/pmacct/files/patch-Makefile.am
  head/net-mgmt/pmacct/files/patch-Makefile.in
  head/net-mgmt/pmacct/pkg-plist