Bug 238490 - www/apache24: Q/A warns about missing dependencies for bdb and gdbm
Summary: www/apache24: Q/A warns about missing dependencies for bdb and gdbm
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-apache mailing list
URL: https://reviews.freebsd.org/D20604
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2019-06-11 08:24 UTC by Palle Girgensohn
Modified: 2020-03-15 11:43 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (apache)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Palle Girgensohn freebsd_committer 2019-06-11 08:24:14 UTC
When building www/apache24 with relevant config as

$ grep '^OPTIONS.*DB' /usr/local/etc/poudriere.d/options/www_apache24/options                                                                           git:(pingpong) 
OPTIONS_FILE_SET+=AUTHN_DBD
OPTIONS_FILE_SET+=AUTHN_DBM
OPTIONS_FILE_SET+=AUTHZ_DBD
OPTIONS_FILE_SET+=AUTHZ_DBM
OPTIONS_FILE_SET+=DBD
OPTIONS_FILE_SET+=SOCACHE_DBM
OPTIONS_FILE_SET+=SESSION_DBD


Q/A warns about missing dependencies:

Error: /usr/local/bin/ab is linked to /usr/local/lib/libdb-5.3.so.0 from databases/db5 but it is not declared as a dependency
Warning: you need USES+=bdb
Error: /usr/local/bin/ab is linked to /usr/local/lib/libgdbm.so.6 from databases/gdbm but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libgdbm.so:databases/gdbm
Comment 1 Bernard Spil freebsd_committer 2020-03-15 11:43:21 UTC
Hi Palle,

Closing this ticket, not a bug in Apache. You could call it a bug in the Q/A code.

You are seeing the Q/A warning because of the devel/apr1 dependency.
If you build devel/apr1 with any of the "Database support" options (BDB and GDMB are selected by default), you will have a libaprutil-1.so that is linked against the respective database shared libs.
The Apache build uses the output of apu-1-config for the compiling and linking of a.o. `support/ab`. Thus the `ab` utility is linked with libdb-5 and libgdbm.

Cheers, Bernard (with hat apache@)