Bug 238519 - sysutils/py-ansible-lint: Missing dependency
Summary: sysutils/py-ansible-lint: Missing dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthew Seaman
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-06-12 10:09 UTC by Mateusz Piotrowski
Modified: 2019-07-01 05:48 UTC (History)
0 users

See Also:
matthew: maintainer-feedback+
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Piotrowski freebsd_committer 2019-06-12 10:09:12 UTC
I get the following error:

> $ ansible-lint
> Traceback (most recent call last):
>   File "/usr/local/bin/ansible-lint", line 6, in <module>
>     from pkg_resources import load_entry_point
>   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3241, in <module>
>     @_call_aside
>   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3225, in _call_aside
>     f(*args, **kwargs)
>   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3254, in _initialize_master_working_set
>     working_set = WorkingSet._build_master()
>   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 583, in _build_master
>     ws.require(__requires__)
>   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 900, in require
>     needed = self.resolve(parse_requirements(requirements))
>   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 786, in resolve
>     raise DistributionNotFound(req, requirers)
> pkg_resources.DistributionNotFound: The 'ruamel.yaml' distribution was not found and is required by ansible-lint

I only have ansible-lint installed. I do not have any other ansible packages installed on my machine.

Details:
- FreeBSD 13.0-CURRENT r348877 GENERIC-NODEBUG  amd64
- py36-ansible-lint-4.1.0_1
Comment 1 Mateusz Piotrowski freebsd_committer 2019-06-12 10:16:55 UTC
It looks like it is missing py36-ruamel.yaml and py36-ansible (in my case).
Comment 2 Matthew Seaman freebsd_committer 2019-06-12 10:44:15 UTC
Actually, it's missing all of the RUN_DEPENDS it should have.  Fix is coming right up.
Comment 3 commit-hook freebsd_committer 2019-06-12 13:03:54 UTC
A commit references this bug:

Author: matthew
Date: Wed Jun 12 13:03:03 UTC 2019
New revision: 504010
URL: https://svnweb.freebsd.org/changeset/ports/504010

Log:
  Add all of the inexplicably missing RUN_DEPENDS needed by this port.

  PR:		238519
  Reported by:	0mp

Changes:
  head/sysutils/py-ansible-lint/Makefile
Comment 4 Matthew Seaman freebsd_committer 2019-06-12 13:05:20 UTC
Committed, thanks!
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2019-06-12 13:33:11 UTC
Is quarterly affected? If so please MFH (it does not require approval)