Bug 238525 - sysutils/smartmontools: Add ability to run smartd with arbitrary arguments
Summary: sysutils/smartmontools: Add ability to run smartd with arbitrary arguments
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-12 16:56 UTC by Christian Baltini
Modified: 2019-06-13 17:15 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (samm)


Attachments
Example of changes to allow arbitrary arguments on smartd launch (941 bytes, text/plain)
2019-06-12 16:56 UTC, Christian Baltini
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Baltini 2019-06-12 16:56:32 UTC
Created attachment 205009 [details]
Example of changes to allow arbitrary arguments on smartd launch

Patch demonstrates new service "mysmartd" that allows adding arbitrary smartd arguments via "mysmartd_args"

Propose updating /usr/local/etc/rc.d/smartd to similarly allow arbitrary arguments specified in /etc/rc.conf or /usr/local/etc/rc.conf via "smartd_args".
Comment 1 Dries Michiels 2019-06-13 13:55:41 UTC
Normally you can already specify extra flags through rcname_flags=“flaghere”. This works with every rc script even if it is not specified in the script itself because the rc framework takes account for this. So try with smartd_flags= In rc.conf. The framework will append those flags to the run command.
Comment 2 Christian Baltini 2019-06-13 17:12:44 UTC
Wow, somehow I've never come across this before.  Very good to know, thanks!
Comment 3 Dries Michiels 2019-06-13 17:15:15 UTC
I think it is not common knowledge under the users although very usefull. We should document this somewhere. :-)