Bug 238561 - sysutils/google-compute-engine-oslogin: Fix OSLogin
Summary: sysutils/google-compute-engine-oslogin: Fix OSLogin
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Larry Rosenman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-14 13:25 UTC by Lucas Kanashiro
Modified: 2019-11-03 17:00 UTC (History)
2 users (show)

See Also:


Attachments
fix OSLogin (4.22 KB, patch)
2019-06-14 13:25 UTC, Lucas Kanashiro
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Kanashiro 2019-06-14 13:25:05 UTC
Created attachment 205059 [details]
fix OSLogin

Larry Rosenman and Glen Barber from the FreeBSD team reported that the OSLogin feature has not been working since the last update I made to sysutils/google-compute-engine-oslogin ports package. I found out that the problem is in some modifications made by upstream in the shell script responsible to activate and deactivate the feature. I prepared the attached patch to fix it. With the patch applied in a FreeBSD 13 instance on GCE I was able to use the OSLogin feature without any problem. I also sent this same patch upstream.
Comment 1 commit-hook freebsd_committer 2019-06-14 13:51:01 UTC
A commit references this bug:

Author: ler
Date: Fri Jun 14 13:50:26 UTC 2019
New revision: 504192
URL: https://svnweb.freebsd.org/changeset/ports/504192

Log:
  sysutils/google-compute-engine-oslogin: fix OSLogin

  Larry Rosenman and Glen Barber from the FreeBSD team reported that the OSLogin
  feature has not been working since the last update I made to
  sysutils/google-compute-engine-oslogin ports package. I found out that the
  problem is in some modifications made by upstream in the shell script
  responsible to activate and deactivate the feature. I prepared the attached
  patch to fix it. With the patch applied in a FreeBSD 13 instance on GCE I was
  able to use the OSLogin feature without any problem. I also sent this same
  patch upstream.

  PR:		238561
  Submitted by:	lucas.kanashiro@collabora.com (maintainer)

Changes:
  head/sysutils/google-compute-engine-oslogin/Makefile
  head/sysutils/google-compute-engine-oslogin/files/
  head/sysutils/google-compute-engine-oslogin/files/patch-bin_google__oslogin__control
Comment 2 Larry Rosenman freebsd_committer 2019-06-14 13:55:31 UTC
Committed, Thanks!
Comment 3 Peter 2019-10-02 16:11:23 UTC
still an issue - work continued in:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=238560
Comment 4 commit-hook freebsd_committer 2019-11-03 17:00:25 UTC
A commit references this bug:

Author: rakuco
Date: Sun Nov  3 16:59:41 UTC 2019
New revision: 516443
URL: https://svnweb.freebsd.org/changeset/ports/516443

Log:
  Update to 20191018.00.

  Follow-up to bug 238561, which did not fully fix the port.

  Major changes in the package:
  - Upstream moved to another github repo
  - Upstream versioning numbering changed to dates

  The patches that area included were already sent upstream.

  The only missing feature is the usage of oslogin in the group database that is
  not working (it causes "sudo su" with an oslogin user to stall). But this
  wans't present in the last version, so it is left disabled for now until we
  have a better solution.

  PR:		238561
  PR:		238560
  Submitted by:	Helen Koike <helen.koike@collabora.com>
  Tested by:	Helen Koike <helen.koike@collabora.com>
  MFH:		2019Q4

Changes:
  head/sysutils/google-compute-engine-oslogin/Makefile
  head/sysutils/google-compute-engine-oslogin/distinfo
  head/sysutils/google-compute-engine-oslogin/files/patch-bin_google__oslogin__control
  head/sysutils/google-compute-engine-oslogin/files/patch-google__oslogin__control
  head/sysutils/google-compute-engine-oslogin/files/patch-src_Makefile
  head/sysutils/google-compute-engine-oslogin/files/patch-src_nss_nss__cache__oslogin.c
  head/sysutils/google-compute-engine-oslogin/files/patch-src_nss_nss__oslogin.cc
  head/sysutils/google-compute-engine-oslogin/pkg-descr
  head/sysutils/google-compute-engine-oslogin/pkg-plist