Bug 238599 - shells/ammonite: Update to 1.6.8
Summary: shells/ammonite: Update to 1.6.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kai Knoblich
URL: http://ammonite.io/#1.6.8
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-16 08:41 UTC by Jens Grassel
Modified: 2019-06-22 09:03 UTC (History)
1 user (show)

See Also:
freebsd-ports: maintainer-feedback+


Attachments
Update shells/ammonite to 1.6.8 (882 bytes, patch)
2019-06-16 08:41 UTC, Jens Grassel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Grassel 2019-06-16 08:41:30 UTC
Created attachment 205105 [details]
Update shells/ammonite to 1.6.8

Hi,

I've attached a patch to update the shells/ammonite port to the latest version (1.6.8).

Changelog: http://ammonite.io/#Changelog

* Support for Scala 2.13.0
* Fix regression in source builtin (#964)
* Autocomplete for import $ivy statements (#957)

Regards,

Jens
Comment 1 commit-hook freebsd_committer 2019-06-22 09:02:03 UTC
A commit references this bug:

Author: kai
Date: Sat Jun 22 09:01:14 UTC 2019
New revision: 504855
URL: https://svnweb.freebsd.org/changeset/ports/504855

Log:
  shells/ammonite: Update to 1.6.8

  Changelog since 1.6.5:

  * Support for Scala 2.13.0
  * Fix regression in "source" builtin
  * Autocomplete for "import $ivy" statements

  PR:		238599
  Submitted by:	Jens Grassel <freebsd-ports@jan0sch.de> (maintainer)

Changes:
  head/shells/ammonite/Makefile
  head/shells/ammonite/distinfo
Comment 2 Kai Knoblich freebsd_committer 2019-06-22 09:03:18 UTC
Committed, thanks!