Bug 238616 - games/aquaria : update to include dirent.h instead of deprecated sys/dir.h
Summary: games/aquaria : update to include dirent.h instead of deprecated sys/dir.h
Status: Closed DUPLICATE of bug 238617
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords:
Depends on:
Blocks: 21519
  Show dependency treegraph
 
Reported: 2019-06-16 13:49 UTC by Rene Ladan
Modified: 2019-06-16 15:00 UTC (History)
1 user (show)

See Also:
jbeich: maintainer-feedback+


Attachments
include dirent.h instead of sys/dir.h (1.53 KB, patch)
2019-06-16 13:49 UTC, Rene Ladan
jbeich: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Ladan freebsd_committer 2019-06-16 13:49:44 UTC
Created attachment 205130 [details]
include dirent.h instead of sys/dir.h

This port includes sys/dir.h, which is scheduled for removal. Let it include dirent.h instead as suggested.

While here update USES to modern standards.
Comment 1 Jan Beich freebsd_committer 2019-06-16 14:25:43 UTC
Comment on attachment 205130 [details]
include dirent.h instead of sys/dir.h

I had the same change bitrotting in my "warnings" branch waiting for upstream to fix on their own.
https://github.com/AquariaOSE/Aquaria/commit/5395b9bcb414
https://github.com/AquariaOSE/Aquaria/issues/23
Comment 2 Jan Beich freebsd_committer 2019-06-16 14:40:18 UTC
Feel free to land if it builds.
Comment 3 commit-hook freebsd_committer 2019-06-16 14:57:56 UTC
A commit references this bug:

Author: rene
Date: Sun Jun 16 14:57:51 UTC 2019
New revision: 504349
URL: https://svnweb.freebsd.org/changeset/ports/504349

Log:
  games/aquaria: include dirent.h instead of sys/dir.h which is scheduled for removal.

  While here modernize USES

  PR:		238616
  Approved by:	maintainer (jbeich)
  Event:		Berlin Hackathon 2019

Changes:
  head/games/aquaria/Makefile
  head/games/aquaria/files/patch-ExternalLibs_ttvfs_VFSTools.cpp
Comment 4 Rene Ladan freebsd_committer 2019-06-16 15:00:05 UTC
Duplicate of 238617

*** This bug has been marked as a duplicate of bug 238617 ***