Bug 238617 - games/aquaria : update to include dirent.h instead of deprecated sys/dir.h
Summary: games/aquaria : update to include dirent.h instead of deprecated sys/dir.h
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords:
: 238616 (view as bug list)
Depends on:
Blocks: 21519
  Show dependency treegraph
 
Reported: 2019-06-16 13:50 UTC by Rene Ladan
Modified: 2019-06-16 15:00 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (jbeich)


Attachments
include dirent.h instead of sys/dir.h (1.53 KB, patch)
2019-06-16 13:51 UTC, Rene Ladan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Ladan freebsd_committer 2019-06-16 13:50:21 UTC
This port includes sys/dir.h, which is scheduled for removal. Let it include dirent.h instead as suggested.

While here update USES to modern standards.
Comment 1 Rene Ladan freebsd_committer 2019-06-16 13:51:15 UTC
Created attachment 205131 [details]
include dirent.h instead of sys/dir.h
Comment 2 Rene Ladan freebsd_committer 2019-06-16 14:58:58 UTC
Committed, thanks.
Comment 3 Rene Ladan freebsd_committer 2019-06-16 15:00:05 UTC
*** Bug 238616 has been marked as a duplicate of this bug. ***