Bug 238679 - net/nss-pam-ldapd-sasl: Build Error: '/usr/bin/env python' is an invalid shebang
Summary: net/nss-pam-ldapd-sasl: Build Error: '/usr/bin/env python' is an invalid shebang
Status: Closed DUPLICATE of bug 239255
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Ryan Steinmetz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-18 08:18 UTC by O. Hartmann
Modified: 2019-10-09 19:53 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (zi)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2019-06-18 08:18:34 UTC
On CURRENT (FreeBSD 13.0-CURRENT #169 r349150: Mon Jun 17 21:19:01 CEST 2019 amd64) port net/nss-pam-ldapd-sasl fails to build/upgrade/reinstall due to:

[...]
Making install in tests
====> Compressing man pages (compress-man)
===> Staging rc.d startup script(s)
====> Running Q/A tests (stage-qa)
Error: '/usr/bin/env python' is an invalid shebang you need USES=shebangfix for 'share/nslcd-utils/getent.py'
Error: '/usr/bin/env python' is an invalid shebang you need USES=shebangfix for 'share/nslcd-utils/chsh.py'
Warning: Bad symlink '/usr/local/bin/getent.ldap' pointing to an absolute pathname '/usr/local/share/nslcd-utils/getent.py'
Warning: Bad symlink '/usr/local/bin/chsh.ldap' pointing to an absolute pathname '/usr/local/share/nslcd-utils/chsh.py'
Warning: /usr/ports/net/nss-pam-ldapd-sasl/work/stage/usr/local/lib/pam_ldap.so.1 doesn't have a SONAME.
Warning: pkg(8) will not register it as being provided by the port.
Warning: If another port depend on it, pkg will not be able to know where it comes from.
Warning: It is directly in /usr/local/lib, it is probably used by other ports.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net/nss-pam-ldapd-sasl
*** Error code 1

Stop.
make: stopped in /usr/ports/net/nss-pam-ldapd-sasl

===>>> make stage failed for net/nss-pam-ldapd-sasl
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> net/nss-pam-ldapd-sasl
Comment 1 O. Hartmann 2019-10-09 19:53:50 UTC

*** This bug has been marked as a duplicate of bug 239255 ***