Bug 238760 - net/quagga: ripd aborts on rip_timeout (1.2.4)
Summary: net/quagga: ripd aborts on rip_timeout (1.2.4)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Eugene Grosbein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-22 09:33 UTC by Eugene Grosbein
Modified: 2019-07-06 14:10 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (pi)


Attachments
Workaround patch (399 bytes, patch)
2019-06-22 09:33 UTC, Eugene Grosbein
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Grosbein freebsd_committer 2019-06-22 09:33:16 UTC
Created attachment 205280 [details]
Workaround patch

I see multiple repeatable crashes of ripd triggered by an assert.

The problem was reported upstream over a year ago (2018-04-12) by another person but the PR is still in UNCONFIRMED state there and got no attention:

https://bugzilla.quagga.net/show_bug.cgi?id=985

I reported my own analisys of the problem with workaround patch eliminating crash there:

https://bugzilla.quagga.net/show_bug.cgi?id=1008

However, I doubt it will be resolved upstream in foreseeable future. Please consider adding this patch to the port meantime.
Comment 1 commit-hook freebsd_committer 2019-07-06 14:09:08 UTC
A commit references this bug:

Author: eugen
Date: Sat Jul  6 14:08:36 UTC 2019
New revision: 505996
URL: https://svnweb.freebsd.org/changeset/ports/505996

Log:
  net/quagga: unbreak ripd for 1.2.4

  ripd is essentially non-functional in quagga-1.2.4
  as it aborts on first announce timeout due to some threading logic bug.

  The problem was reported upstream over a year ago and ignored:
  https://bugzilla.quagga.net/show_bug.cgi?id=985
  https://bugzilla.quagga.net/show_bug.cgi?id=1008

  Add work-around that restores ripd stability.

  PR:		238760
  Approved by:	pi (maintainer timeout, 2 weeks)

Changes:
  head/net/quagga/Makefile
  head/net/quagga/files/patch-lib_thread.c
Comment 2 Eugene Grosbein freebsd_committer 2019-07-06 14:10:04 UTC
Temporary fix committed.