Bug 238790 - devel/talloc: talloc1 can't coexist with talloc - dependency conflicts
Summary: devel/talloc: talloc1 can't coexist with talloc - dependency conflicts
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Timur I. Bakeyev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-24 14:45 UTC by Petr Fischer
Modified: 2019-07-07 11:00 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (timur)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Fischer 2019-06-24 14:45:17 UTC
In the last days I have problem with talloc dependencies - the main problem is that talloc can't coexist with talloc1 (header files conflict) and:

samba48 requires talloc1
fusefs-smbnetfs + gnome-vfs + gvfs requires samba48

notmuch requires talloc
neomutt requires notmuch

So - I can't have installed fusefs-smbnetfs + neomutt.

Maybe this is the responsibility of dependent package mantainers - I have no idea how to resolve these conflicts.

Is new talloc fully compatible with talloc1 (can I change port dependency from talloc1 to the talloc in dependent ports and rebuild)?
Comment 1 Petr Fischer 2019-06-24 22:48:44 UTC
Sorry, version:

➤  freebsd-version -ku
11.2-RELEASE-p10
11.2-RELEASE-p10
Comment 2 crest 2019-07-02 15:09:58 UTC
You're not alone with your requirements (neomutt + notmuch and samba48)
Comment 3 commit-hook freebsd_committer 2019-07-02 19:08:06 UTC
A commit references this bug:

Author: timur
Date: Tue Jul  2 19:07:55 UTC 2019
New revision: 505699
URL: https://svnweb.freebsd.org/changeset/ports/505699

Log:
  Another attempt to work around the t{alloc,db,event}1 <-> t{alloc,db,event} conflict
  if there are installations of samba48 and other consumers of those libs.

  With /etc/make.conf settings of:

  SAMBA4_BUNDLED_TALLOC=		yes
  SAMBA4_BUNDLED_TEVENT=		yes
  SAMBA4_BUNDLED_TDB=		yes

  the samba48 port will be statically linked with bundled libraries and won't depend on any
  external t{alloc,db,event}.

  Ldb here stands out, as even with bundled version same binaries are installed where the ldb13
  installs them. For this situation it's adviced to set:

  SAMBA4_BUNDLED_LDB=		no

  and make sure that all LDB dependant ports use the same ldb13 dependency.

  PR:		238790

Changes:
  head/net/samba48/Makefile
  head/net/samba48/files/patch-lib_ldb_wscript
  head/net/samba48/pkg-plist
Comment 4 Petr Fischer 2019-07-07 11:00:57 UTC
Solved in samba48: 4.8.12_3