Bug 239012 - jexec(8) doesn't change directory into the user's home directory in jail
Summary: jexec(8) doesn't change directory into the user's home directory in jail
Status: Closed Works As Intended
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-doc (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-06 06:04 UTC by Yuri Victorovich
Modified: 2021-02-16 18:44 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2019-07-06 06:04:38 UTC
When the user set with -U {uid}, jexec properly sets the HOME environment variable, but doesn't chdir into this directory, and runs the command in /.
Comment 1 Yuri Victorovich freebsd_committer 2019-07-06 06:18:57 UTC
Actually, there is an undocumented argument -l (clean) which does what the subject asks, and which needs to be documented in the man page.
Comment 2 Michael Zhilin 2019-08-22 13:49:30 UTC
Hi, yuri!

I see man page contains "-l" parameter according to:
https://svnweb.freebsd.org/base?view=revision&revision=285420

Is it not enough?

Thanks!
Comment 3 Fernando Apesteguía freebsd_committer 2021-02-16 18:16:11 UTC
^Triage: the related option seems to be documented.
Comment 4 Yuri Victorovich freebsd_committer 2021-02-16 18:44:05 UTC
jexec(8) has -l in 14-CURRENT, but not in 12.2-STABLE.

But this is a minor thing.