Bug 239030 - [panic] inserting non empty CD
Summary: [panic] inserting non empty CD
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.2-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: panic
Depends on:
Blocks:
 
Reported: 2019-07-07 10:04 UTC by ml
Modified: 2019-07-08 18:05 UTC (History)
2 users (show)

See Also:


Attachments
patch (1.21 KB, patch)
2019-07-08 15:39 UTC, Mark Johnston
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ml 2019-07-07 10:04:21 UTC
(#219074 is similar in subject, but stack trace is different).

Today I wanted to record a CDRW, I inserted a non empty one (which I intended to blank) and my system crashed.

#0  doadump (textdump=<value optimized out>) at pcpu.h:233
	in pcpu.h
(kgdb) #0  doadump (textdump=<value optimized out>) at pcpu.h:233
#1  0xffffffff805755db in kern_reboot (howto=260)
    at /usr/src/sys/kern/kern_shutdown.c:383
#2  0xffffffff80575a01 in vpanic (fmt=<value optimized out>, 
    ap=<value optimized out>) at /usr/src/sys/kern/kern_shutdown.c:776
#3  0xffffffff80575843 in panic (fmt=<value optimized out>)
    at /usr/src/sys/kern/kern_shutdown.c:707
#4  0xffffffff807f516f in trap_fatal (frame=0xfffffe01f3916a60, eva=8)
    at /usr/src/sys/amd64/amd64/trap.c:875
#5  0xffffffff807f51c9 in trap_pfault (frame=0xfffffe01f3916a60, usermode=0)
    at pcpu.h:233
#6  0xffffffff807f49c7 in trap (frame=0xfffffe01f3916a60)
    at /usr/src/sys/amd64/amd64/trap.c:415
#7  0xffffffff807d668c in calltrap ()
    at /usr/src/sys/amd64/amd64/exception.S:231
#8  0xffffffff804ecd4e in g_dev_orphan (cp=0xfffff8002d1b9700)
    at /usr/src/sys/geom/geom_dev.c:761
#9  0xffffffff804f5081 in g_resize_provider_event (arg=<value optimized out>, 
    flag=<value optimized out>) at /usr/src/sys/geom/geom_subr.c:631
#10 0xffffffff804f04ce in g_run_events ()
    at /usr/src/sys/geom/geom_event.c:264
#11 0xffffffff80541a63 in fork_exit (
    callout=0xffffffff804f2890 <g_event_procbody>, arg=0x0, 
    frame=0xfffffe01f3916c00) at /usr/src/sys/kern/kern_fork.c:1054
#12 0xffffffff807d75be in fork_trampoline ()
    at /usr/src/sys/amd64/amd64/exception.S:960
#13 0x0000000000000000 in ?? ()
Current language:  auto; currently minimal
(kgdb) 


Possibly devd or some other component (from XFCE?) tried to access the disk, alhough I didn't ask to mount it in any way.

Notice this is my first multi-user boot after the upgrade to 11.2-RELEASE-p11: this might be related or not to FreeBSD-SA-19:11.cd_ioctl, but it never happened before.
Comment 1 Mark Johnston freebsd_committer 2019-07-07 16:18:48 UTC
I don't believe this is related to the SA.

Could you provide the core.txt from this crash?
Comment 2 ml 2019-07-08 09:17:52 UTC
I've tried attaching it several times, but connection always times out.
Please, find it here:
https://www.netfence.it/download/core.txt.2

Notice I've made some other tests and was unable to reproduce this crash again.
Comment 3 Mark Johnston freebsd_committer 2019-07-08 15:39:17 UTC
Created attachment 205586 [details]
patch

Thanks.  My guess is that this would be fixed by r323977, which is unfortunately not present in 11.x.  If you're able to test kernel patches, please try the attached diff.