Bug 239128 - audio/swhplugins: fix shared library errors
Summary: audio/swhplugins: fix shared library errors
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-11 00:43 UTC by Marcel Bonnet
Modified: 2019-07-11 07:35 UTC (History)
1 user (show)

See Also:


Attachments
Makefile diff (279 bytes, patch)
2019-07-11 00:43 UTC, Marcel Bonnet
no flags Details | Diff
dmesg output (2.54 KB, text/plain)
2019-07-11 00:47 UTC, Marcel Bonnet
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Bonnet 2019-07-11 00:43:36 UTC
Created attachment 205681 [details]
Makefile diff

When running linuxsampler I found errors related to shared libraries from audio/swhplugins .

Linuxsampler messages:

$ linuxsampler --instruments-db-location instrumentos.db
LinuxSampler 2.0.0                                                                     
Copyright (C) 2003,2004 by Benno Senoner and Christian Schoenebeck   
Copyright (C) 2005-2015 Christian Schoenebeck                       
Detected features: disabled at compile time                        
Automatic Stacktrace: Off                                             
Creating Sampler...OK                                             
Registered sampler engines: 'GIG','SF2','SFZ'                     
Registered MIDI input drivers: JACK                                
Registered audio output drivers: JACK                              
Loading instrument editor plugins...OK                                          
Registered instrument editors:                                       
Registered internal effect systems: LADSPA                                    
failed to load DLL: '/usr/local/lib/ladspa/imp_1199.so', cause: /usr/local/lib/ladspa/imp_1199.so: Undefined symbol "mk_imps"
failed to load DLL: '/usr/local/lib/ladspa/gong_1424.so', cause: /usr/local/lib/ladspa/gong_1424.so: Undefined symbol "waveguide_nl_process"
failed to load DLL: '/usr/local/lib/ladspa/sifter_1210.so', cause: /usr/local/lib/ladspa/sifter_1210.so: Undefined symbol "q_sort"
Registered internal effects: 239                                                 
Starting LSCP network server (0.0.0.0:8888)...Thread: WARNING, can't mlockall() memory!
OK                                                                
LinuxSampler initialization completed. :-)


I changed the Makefile of audio/swhplugins to:

--- Makefile.orig       2019-07-10 21:38:35.532167000 -0300
+++ Makefile    2019-07-10 21:33:08.596835000 -0300
@@ -24,7 +24,7 @@
 LDFLAGS+=      -L${LOCALBASE}/lib
 USE_LDCONFIG=  yes
 
-CFLAGS+=       -fPIC -DPIC 
+CFLAGS+=       -fPIC -DPIC -std=gnu89
 
 OPTIONS_DEFINE=        NLS 3DNOW SSE
 OPTIONS_SUB=   yes

And now linuxsampler do not complains :

$    linuxsampler --instruments-db-location instrumentos.db
LinuxSampler 2.0.0
Copyright (C) 2003,2004 by Benno Senoner and Christian Schoenebeck
Copyright (C) 2005-2015 Christian Schoenebeck
Detected features: disabled at compile time
Automatic Stacktrace: Off
Creating Sampler...OK
Registered sampler engines: 'GIG','SF2','SFZ'
Registered MIDI input drivers: JACK
Registered audio output drivers: JACK
Loading instrument editor plugins...OK
Registered instrument editors:
Registered internal effect systems: LADSPA
Registered internal effects: 242
Starting LSCP network server (0.0.0.0:8888)...Thread: WARNING, can't mlockall() memory!
OK
LinuxSampler initialization completed. :-)
Comment 1 Marcel Bonnet 2019-07-11 00:47:23 UTC
Created attachment 205682 [details]
dmesg output

FreeBSD machine.STUDIO 12.0-STABLE FreeBSD 12.0-STABLE #2 r344331M: Fri Mar  8 08:36:23 -03 2019     marcelbonnet@machine.STUDIO:/usr/obj/usr/src/amd64.amd64/sys/MACHINE-12  amd64